OSMC does not boot on Raspberry Pi 3 B+

I installed OSMC on 8 GB SD card using OSMC installer from https://osmc.tv/ site on windows laptop.
Installation passed smoothly without errors. I used “Raspberry Pi 2/3” option in installer.
I ejected SD card and plugged into my Raspberry Pi 3 B+ connected via HDMI with TV, but TV didn’t get any signal.
I used Raspbian OS before without any problems.

I also tired multiple relases of OSMC, but none worked.

Do you get anything on the screen? What do the LED lights on the Raspberry Pi do? Can you show us a screenshot of the contents of your SD card.

Thank you for your respond!

Only PWR LED light is lit, ACT is not.

Here is screenshot of content of SD card:

Which image did you use?
I’ve just checked the January image on a 3B + and it worked with success.

I tried three different images: 2020.01-1; 2019.11-1 and 2019.04-1.
In addition to OSMC installer I tried downloading image and making it bootable using rufus.

Have you checked your Raspbian install again? Because not showing any picture on the TV indicates something not working very early in the booting.

Are you using the OSMC disk imaging utility?
Do NOOBS images of OSMC work?

Why do the files on your screenshot have a date of 5 January 2019?

That looks like it’s the 2018.12-1 image.