OSMC does not find Network via SMB


I had to reinstall OSMC on my RP2. Since then OSMC does not find anything in my Network.
Laptop and Main PC are able to see each other and the files and also OSMC.
I tryed reinstalling OSMC again with no results.
Right now I’m using DHCP from the router for IP adresses. The SMB options are set to default (from clean install).
Does anybody have an Idea what I can try? I’m stuck.


SMB Browsing has been disabled due to security issues

You can still either access it by adding the Network path directly smb:\\SERVER\SHARE or for better performance use FSTAB based mounting

Your last option (not recommended due to security issues) allow smb1 protocol in Settings - Services - SMB Client

I set it to SMBv1 in OSMC and now it works.

Which since Wannacry is quite a unnecessary risk.

Even if it’s my own network?

Well you only need one device in your network with a virus that than can use the WannaCry bug to spread through samba to all devices

Hi @BaseTea,
just to ensure to avoid confusion. You changed in Settings - Services - SMB Client - Maximum protocol version to SMBv1 and with that one change you are able to browse your network via Add Videos - Windows network (SMB)?


1 Like


You can easy use smb by change skin to estuasy. Everything will back as you want

It’s a two years old post, no need to resurrect it.