OSMC does not recognize .zip

I must be doing something wrong.

I installed OSMC on raspberry pi after not being able to use Netflix or pandora on libre elec.
On libreElec I was able to add from zip, just never worked.

So once OSMC was installed I upgraded to Leia 18. I added source from zip in file manager then went to addons install from zip.

When I click my source, which is literally a .zip file, no matter how many folders I open or what I click on I never get the ok button to light up so I can install it. It does this to me on everything I’ve tried to install from zip. There’s nothing that I can find to turn on the “ok” button so I can click it.

Thanks for your help

Provide logs demonstrating the issue or re-install… There is typically no issue in installing from .zip.

Pardon me, I am new. And I have re-installed 3 times. Including updating and upgrading to v18.
It is my understanding that something that does NOT happen does NOT generate a log entry. Not sure how I would get the log to my phone to share it if I did.
But as I mentioned adding from zip worked on libreElec, just not working on OSMC.

Maybe I did a bad job explaining what is actually wrong.

I’ll try again, I add source in file manager, then install from zip in addons.

I see my source .zip file I added on the screen in the list with the other sources.

I click on the source I want to install from zip.
It shows me folders inside the zip.

There is a box on my right that says ok and beneath it a box that says cancel.
The cancel control is always highlighted and the OK control is never highlighted.

So I click every folder in every sub folder trying to turn the ok control on and nothing does.

I end up having to back out or click cancel because OK will never be enabled.

Will this generate a log entry?


See How to submit a useful support request - General - OSMC

Is this a publicly available source? Tell us what addon you are trying to install by zip and someone else can test for function with their OSMC system.

Thank you Action.
The source for the (pandora) pandoki addons is https://github.com/gominoa/gominoa-xbmc-addons/raw/master/repo/plugin.audio.pandoki/plugin.audio.pandoki-0.9.3.zip

And (netflix):

So at the endo of the day all I really want is KODI 18, Netflix, pandora, YouTube and a vpn. Dont really care how I get it there as long as it works.

Again the whole problem may be that I’m doing something wrong, left a box unchecked or something stupid (outside sources is turned on) like that. I just dont know.

Oh yeah, raspberry_pi 3b+
I’m getting close to loading an android OS and doing it that way, but to me that’s like putting an old iron block Chevy motor in a Ferrari. I kinda want to exhaust all other options first

Well I guess so, as you can see in the Netflix thread many people use “Install from zip file” on a daily base:

So did you download the file to /home/osmc/ and tried to install from home directory? Does the file has the right permissions?

ZIP file installation is working OK here.
Without any logs from OP, it will be impossible to know what’s going wrong.

I did follow those instructions. Did the update and the upgrade and got the certification installed according to the instructions on osmc website. Now the save /home/osmc/
This is the first I’m hearing of this instruction. How do I go about telling it where to save to?
And I have no idea what permissions are needed but I was operating under the premise that I have SU authority (#root)

I feel like you may be very close to sending me in the right direction and pointing out my mistake.

I want you to know I very much appreciate your time to teach me.

Try and install your ZIP
When nothing happens, go to My OSMC -> Logs and upload all logs and send us the URL.

Well if you execute wget https://github.com/asciidisco/plugin.video.netflix/archive/master.zip in the directory /home/osmc than it will be saved there.

If you followed those instructions point by point than your permissions should be ok. You actually in that regard should not use su or root for any of the wget commands!

1 Like

Sam, what I do not understand about the logs… wow where do I begin. First, I dont have a browser on the pi so that I can use it to access this forum and thereby post the log. So how would I go about posting it? I read your thread about a useful post and most of what you said is gibberish to me. I mean i see you say insert tab A into slot B while I’m over here what’s a slot and how would one insert something into it.
Maybe you guys are all bill gates and Steve jobs, but I’m a humble airplane mechanic with a 3d printer and his first rpi…

I dont mean to be short with you at all, so pardon me if it comes across that way but if you want me to do something i need very detailed instructions on how to perform every step.
You could say go to this directory and I’m say what directory and where isit and how do i get there.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Ok well, now I think I get what you’re saying. But I dont get to install from zip because the “Ok” button never becomes active. It remains grey so I cannot “try” to install from zip because I never get to a point where I have the option to try.

I’m gonna try the other fellas instruction to save to directory. And let’s see what happens there. I’m hoping I only missed a step because I didnt know what it meant and did something else. I’ll let yall know in a moment.

Please tell me how to get into the directory so I can execute that wget there.

When logging in, you will always find yourself in the user’s home directory. You are already there.

1 Like


  1. To change a directory you use cd so the command is cd /home/osmc
  2. ~ actually is equal to the users home directory so in your case it is /home/osmc
  3. While generally dir is a bit of a strange command on linux (on linux you use ls) it did the job and showed you the content of the directory and as you can see it seems you haven’t downloaded the file.

Maybe you want to read up some linux basics if you struggle with the given instructions.


Ok Fzinkin that worked. It installed!
Thanks to all of you who took time to sort me out.
It did install from zip but it said there is an error and to see log.

So now I get to learn to use the log by following above instructions.

Muchos gracias

Sam, here is the url the logging thing gave me.

Saving it to home directory using wget fixed my install from zip problem. Now there is a Netflix error. That’s what should be on the log but I dont know how to view the log…

0okni clicked on the link I gave you and that looks like the most useless single line of nothing I could imagine.