OSMC does not show the 3.5 mm jack as an audio output option

So far I am loving osmc’s implementation. It is really incredible what the team has done. One problem that I keep on running into is that I only have HDMI output options, no 3.5 mm jack option. I have a raspberry pi 4 running the latest version of osmc. It is connected to a tv via HDMI but I would like the audio to go through the overheads instead of the tv. The overhead speakers are on analogue which I have a converter for so that I can plug it into the 3.5 mm jack on the pi4. Whenever I go to audio devices in the settings it only gives me two hdmi options, no analogue. I saw a similar problem with the pi3 but that fix didn’t work for me assuming I did it right. I have already checked that the adapter and the speakers work.

This is covered here:

Thanks, I tried it yesterday and it worked! I had already tried that solution but I must have not been putting the configs in properly. This time I was able to put them in in the correct way. Thanks for the help!

1 Like

Glad to hear.