OSMC doesn't install


I have a Pi 2 model B. I had KODI on it before and ran into the infinite restart loop and thought that would be a good time to upgrade to OSMC. I ran the installer on Windows, and when I go to boot up my Pi all I get on the screen is a static multi-colored test pattern which just remains that way indefinitely.

I’ve tried SD card install, USB install, various versions or RC and 2015.06-1 all with the same result.

Anyone know what my problem might be?

Sounds like a bad power supply, try another one

If you just get the four coloured pattern then almost certainly you are using the wrong install image. Make sure you are selecting Raspberry Pi 2 for a Pi 2 or Raspberry Pi 1 for any of the earlier models.

A faulty SD card is also a possibility.

I should have mentioned that I tried that with a Motorola plug I know to be a good solid clean plug adapter and cord. Same issue. Also I’m using the same PS as I always have with this Pi2 (though I guess that could have caused the infinite reboot, but why after well over 6 months steady use?).

I suppose it could be faulty SD card. Might that have initiated the infinite reboot look of my Kodi install. I’m definitely choosing the correct installer. I have a clear case and can clearly see that it’s a model B - VI 2 on the board.

So you have a big black chip on the middle of the bottom side of the board ?

There are two main reason for problems installing OSMC:

  • Insufficient power-supply
  • Problems with the SD card

I’ve seen both. So if the power supply ist strong enóugh just try to change the SD card.

yes, and the big black chip reads Samsung 440 and then a string of numbers-RGC2

I’ll try yet another PS. I tried reformatting the SD card with SD Formatter. Any good way of checking for errors as I don’t have a spare micro-sd just lying around?

Pretty sure from re-reading what you wrote that you actually have a Pi 1 B+ not a Pi 2 B.

A Pi 1 B+ board will say Raspberry Pi Model B+ V1.2 while on a Pi 2 it says Raspberry Pi 2 Model B v1.1.

One way to tell for sure - try the Pi 1 image and if that works you have a Pi 1…

Well here I am all red in the face because I didn’t know what I had. My eyes couldn’t see the ‘dot’ in V 1.2 through the case. Now I’m watching OSMC installing right now.

Thanks everyone for so quickly jumping in and helping me out!