OSMC DVB-T / Tvheadend Data Errors


I received my shiny new official OSMC DVB-T stick today, and after some initial problems getting Tvheadend to scan (kept just going to 100% straight away) and then getting it to scan but not picking up any HD channels (seems I needed to just setup the Panasonic DVB-T tuner, not the Realtek) I have it working! Also, sometimes I’d only see the Realtek and not the Panasonics… odd.

I couldn’t get the “Watch TV” part of Tvheadend to work (“An unknown error occurred”) but I did manage to get the streams to playback in VLC and Kodi. However, every so often there’s glitches in the broadcast and I’m not sure what I can do to prevent them, if anything. When recording, these show up as “Data errors”. I had thought that perhaps the USB/Network bus was getting overloaded and so I tried saving the recordings to the SD card instead of a NFS share. Still there are glitches, but less than there were when saving to the share. Oddly though, I couldn’t get the glitches to rack up again when starting playing a movie over an NFS share at the same time to test out my theory.

Anyway, is this just a limitation of the hardware, would an upgrade from a RiPi 2 to a 3B+ make any difference and is there anything I can enable log wise to troubleshoot?

On the TV and hardware freeview DVD Recorder the signal strength and quality are at maximum, I believe I have line of sight to the Saddleworth transmitter at the top of the hill.

Playing back BBC One (non HD) signal strength in Tvheadend is 83% / 34.4 db SNR.
BBC One HD 77% / 29.9 dB SNR.

There are no transport errors or continuity errors in the input stats since I’ve had it installed.

Happy to provide logs; I’m new to Tvheadend so I’m still fumbling my way around it.

Thanks in advance for any pointers.


For comparison, my signal strength is currently 66%/27dB and I experience only occasional glitches. A signal problem generally looks like blocking artifacts. A problem in the Pi/network is more likely to be dropouts.

I used to use a Pi2B as TVheadend server with no problems, albeit not with an OSMC stick.

Certainly, debug logs would help.

There’s still some issues with softirqs on Pi sometimes that cause DVB issues Jamie is describing.

@jamieburchell What version of OSMC are you on?


Hi Sam

It’s 2018.06-1.

I don’t have any other USB devices plugged in, I am using GPIO for Hyperion. 2A power supply.

I will continue to fiddle with it in the meantime.


Can you post a log (from My OSMC) when you get glitches – it might show something.

Your signal strength looks fine.


Hmm I’ve tried watching the stream directly through Kodi (where the stick is plugged in) and there’s no glitches.

Before there were glitches while watching via VLC (over wired gigabit LAN) and when recording. When I get more time I’ll see if I can get it to glitch and send logs.

Do the Kodi logs include tvheadend stuff?

Incidentally, my HD channels have no EPG data and trying to record them from Kodi gives PVR backend error

21:47:44.495 T:1328239360 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command addDvrEntry failed: Could not add dvrEntry
21:47:44.495 T:1328239360 ERROR: PVR - AddTimer - addon ‘Tvheadend:’ returned an error: server error
21:47:44.495 T:1328239360 ERROR: PVR - AddTimer - cannot add timer to client ‘2146250725’: server error

I can record a non HD channel, but when I stop recording it

21:49:51.539 T:1328239360 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command cancelDvrEntry failed: User does not have access
21:49:51.539 T:1328239360 ERROR: PVR - DeleteTimer - addon ‘Tvheadend:’ returned an error: server error

I tried with the osmc/osmc client credentials and without; neither seem to make any difference.

I’m out of time ;(

Maybe you have a VLC issue on the device you’re using.

EPG can take a bit of time to refresh, particularly if you rebooted.
There are also webEPGs which are more reactive to scheduling changes.

My OSMC logs don’t include TVHeadend logs, but I’m not sure we’d benefit from those yet.


Just checking: you should not enable the Realtek - just use the Panasonic.


Yep, I’ve only setup the Panasonic DVB-T and verified the others are not enabled.

Saving to mkv seems to have reduced the number of data errors (but VLC complains of an unrecognised codec now, although audio and video work).

Just tried saving as pass/ts again and lots of data errors.

Here’s a Kodi log:


I have a glitchy .ts recording I could share somewhere if it helps ~210MB. Glitchy in VLC and Windows Media Player.

So I think it’s only recording/network that is a problem as I can’t get any glitches watching directly in Kodi on the same Pi as the stick.

Probably unrelated but I’ve never seen this before - the Pi was completely unresponsive over the network this morning and I needed to pull the plug. This was one of the last lines in the old Kodi log

ERROR: OnTvStandby - Unexpected [standby_pc_on_tv_standby] setting value

When viewing TV over the network and noticing glitches in VLC, the continuity errors increase under the stream status. Is that indicative of a signal problem/interference? Uncorrected blocks remain at zero, so I think this is OK?

FYI I enabled the Freview EPG grabber, hit the rerun button and now have EPG data for the HD streams.

Did you copy guisettings.xml from another device?
It’s nothing to worry about.

Sorry if you told us, but where are you recording to?


Can you enable debug logging under Kodi when you play a channel ?



Don’t think it was copied from another device…

I am writing to a NFS share which is on a Qnap NAS. I also tried writing direct to the SD card but the data errors still clock up.

When I get a chance I’ll enable the debug log and play a bit more :slight_smile:


Ethernet is connected via USB; so a lot of USB activity may be causing problems here.



Full logs here https://paste.osmc.tv/tepuhexozi

If I just watch the HD stream through Kodi on the same Pi as the stick it’s flawless. If I hit record the broadcast is extremely glitchy and basically unusable.

This is a shame, because primarily I was looking for a way to record broadcasts to files easily.

Also I get a backend error when stopping record and although the file stops growing, Kodi thinks it’s still recording.

Is there anything I can do to improve the situation?


Might need to check softirq patches again. This has been a problem in the past. The problem is when we introduce some fixes; it causes regressions for others.

1 Like

I noticed that in the log it says user does not have access to cancel the record. Are the credentials in Kodi for the client the admin credentials? I have osmc/osmc there and also made sure that user has full permission in the tvheadend backend :confused:

You should have permission unless you changed any ACLs.
@grahamh might know a bit more.

Can you take a screenshot of the Users section of the TVH interface?



Sure two ticks I can’t from my iPhone/iPad as logging in to the web ui doesn’t work from there (Bug #5169: Unable to login to web UI on Safari/Chrome - Tvheadend) :slight_smile:

Let me know if you want any others or the config files