OSMC DVB-T / Tvheadend Data Errors

Sure two ticks I can’t from my iPhone/iPad as logging in to the web ui doesn’t work from there (Bug #5169: Unable to login to web UI on Safari/Chrome - Tvheadend) :slight_smile:

Let me know if you want any others or the config files

So I just tried playing the stream as normal, then SSH’d in to the Pi and copied a large file from a read-only NFS share, to the read-write NFS share I setup for recording and reproduced the issue - except it’s worse. The sound has gone and the picture froze for ages. I guess the bus is busy ;(

I was looking at the Pi 3+ before, but that too shares USB/Ethernet, so I guess it wouldn’t even help?

The USB stack remains unchanged across these two devices.
I will do some testing locally and see if I can come up with a solution

Sam

Thanks Sam, much appreciated.

I tested recording directly to the SD card and the situation was much improved. There are still glitches occasionally, especially at the start of the recording - but nowhere near what was happening over the LAN.

Let me know if I can provide any further help or testing :slight_smile:

Cheers
Jamie

I notice you have the * user in your tvh webui. That should not be there if you installed tvh from the AppStore and followed the instructions here: Watching live TV with a USB DVB tuner or network TV tuner

I suggest you reinstall TVH and just accept all of the defaults so we are starting on the same page. The only things I had to do to get the setup I have now were enable the Freeview EPG service and then mess with the mux frequencies [HowTo] Retune TVHeadend DVB for UK Freeview digital switchover

To do a clean-slate installation, uninstall from the AppStore (you did install it from there, didn’t you? - if you used any other method than getting it from the osmc repo then it needs to be uninstalled the same way). Delete or rename the .hts directory in your home folder, then install tvh from the AppStore again as per the above instructions.

I’m not criticising what you’ve done but tvh is a bit of a black box and a sensitive one at that if you don’t do things in the order the developers expect.

I would expect that to work fine with local storage of recordings, then we can set about any networking issues.

Hi @grahamh

I have done a fresh install a couple of times already (removed from App Store, removed .hts folder, installed again).

The only things I’ve done differently are to add an asterisk to the non admin user to allow anyone to access (I don’t need a password at all here really on an internal setup) and to create provider and channel tags. I also set the DVR record location and changed the write file and folder permissions to 666 and 777 respectively so that I can remove the recordings from a user account on the NAS. Reason being OSMC creates the files as osmc:video and those don’t map to accounts on the NAS and the various NFS squash options don’t work. I also experimented with using mkv/ts profiles but reverted to default. I enabled the FreeView EPG so that I could resolve the missing EGP data for HD channels and set the EPG language to UK/English

That said, I’ll start from scratch so we have a clean slate. Thanks for putting the guide together by the way, it was a great help.

Cheers
Jamie

Linus Torvalds himself has commited a change for the softirqs issue in kernel 4.18rc.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/kernel/softirq.c?id=3c53776e29f81719efcf8f7a6e30cdf753bee94d

Might be worth trying that patch.

I am currently an le user and was stuck on a 4.8.x kernel for some time before i eventually found time to bisect the kernel and find the troublesome commit

The torvalds patch was applied to the le kernel and certainly helped me and many others. I’m new to osmc and just waiting for my new vero 4k+ box… cant wait…planning on retiring my old revo 3700 to being purely a tvheadend server on debian with custom kernel having that patch applied.

1 Like

Clean install done. Resolved the “not being able to properly stop a recording” issue by not messing with the default non admin user.

Still glitchy recording to NFS, occasional glitches and data errors writing to the SD card too.

Cheers
Jamie

Thanks for testing. I’ll try TVH and an OSMC stick on my Pi2B tomorrow and see if I can reproduce your glitches.

Should start looking at the Vero4K+ and all your problems would be gone.

1 Like

It’s a possibility. I have a hyperion LED setup using the GPIO pins though so I’d like to keep that somehow. The DVB issue isn’t the end of the world. I’m still impressed by what these little Pis can do. I mainly use it for playing back BD/DVD rips (discs I own) and MP3s (ripped audio collection) and for that it’s perfect. I just purchased the DVB stick to complete the Kodi experience and see if I could easily record DVB to a file.

So I set up with OSMC stick, Pi2B and recording to a USB (spinning, powered) drive and it all works fine as it always has. Then tried recording to an nfs drive through a wifi connection which was a complete disaster. Glitches, then lock-up of kodi. The disk activity light on the NAS continued to flicker as if still recording until pulled the plug on the Pi. The router is some distance from both the Pi and the shared drive.

TBH I’ve never considered saving recordings to a different device than the one I’m running TVH on. For just timeshifting I’ve used the SD card, for keepers I use a USB drive. But then I’ve never bothered to install proper network cabling.

I wonder if your Hyperion setup is giving problems with it, in which case a Pi3+ may help.

Recording to SD was certainly better but there were occasional glitches for me. The Pi is wired to a gigabit router (via a gigabit switch) and my NAS is wired in to the router (gigabit).

I assumed if I tried recording to a USB stick that would exasperate the issue as both devices are connected to the USB bus?

Cheers
Jamie

I saw that softirq patch and I’m aware that there are a couple of variants. Interestingly we seemed to fix the issue for 4.9 but it’s reared its head in 4.14

I used a short USB extender cable between the Pi and the DVB stick so I could access the other USB ports, inserted a 64GB USB thumb drive, fdisk and formatted as ext4, configured tvheadend to write there and there were no glitches. I don’t quite understand the logic there as this is also the USB bus… but it works. I guess it’s not 100% a fair test as in doing this I’ve moved the stick to a port further away from the Ethernet connection and moved the stick further away from potential interference.

1 Like

What PSU do you have?

Hi Sam

I got it a few years back, to be honest I can’t remember exactly. I know it’s at least 2A, maybe 2.1A and a switched power supply - possibly from Maplin (remember them?).

I know what you’re thinking- look at the plug. Thing is it’s a mission to get to right now, the entire TV unit needs to come out so I can open the Belkin power enclosure cover.

If you need specifics let me know and I’ll dig it out.

No expert, but I guess pure USB has fewer overheads than packeting up a stream for a network connection.

Thank you very much both of you for helping me to get this working smoothly. I’m chuffed that I can record to USB without glitches so I’m happy. I appreciate that doesn’t resolve the network issue; if I can help any more with that let me know.

1 Like