OSMC DVB-T2 Adapter not appearing as DVB-T2, Can't Find Channels


I’ve just received my OSMC DVB-T2 but it’s not finding many channels except for the following channels:

That's Hampshire;(null):562000:B8C34D0G32M2T8Y0:T:27500:3501=2:3502=eng@3:0:0:32857:9018:32793:0
POP Max;(null):562000:B8C34D0G32M2T8Y0:T:27500:1101=2:1102=eng@3:0:0:33280:9018:32793:0
Tiny Pop;(null):562000:B8C34D0G32M2T8Y0:T:27500:4901=2:4902=eng@3:0:0:33472:9018:32793:0
That's Thames Valley;(null):578000:B8C34D0G32M2T8Y0:T:27500:3601=2:3602=eng@3:0:0:32873:9018:32809:0
POP Max;(null):578000:B8C34D0G32M2T8Y0:T:27500:1101=2:1102=eng@3:0:0:33280:9018:32809:0
Tiny Pop;(null):578000:B8C34D0G32M2T8Y0:T:27500:4901=2:4902=eng@3:0:0:33472:9018:32809:0
Done, scan time: 06:24.946

I read it should come up as two different adapters but it’s only seeing it as:

I tried rebooting, resetting the adapter and reinstall tv-headend but still can’t see it.

this is how it’s coming up:

osmc@Vero4K:/dev/dvb/adapter0$ dmesg | grep -i dvb
[    3.738206] usb 1-2.3: Product: dvbt2
[    3.738210] usb 1-2.3: Manufacturer: astrometadvbt2
[    5.036910] usb 1-2.3: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
[    5.110707] usb 1-2.3: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[    5.110741] DVB: registering new adapter (Astrometa DVB-T2)
[    5.130819] usb 1-2.3: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    5.183482] input: Astrometa DVB-T2 as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-2/1-2.3/rc/rc1/input9
[    5.183608] rc1: Astrometa DVB-T2 as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-2/1-2.3/rc/rc1
[    5.183831] input: MCE IR Keyboard/Mouse (dvb_usb_rtl28xxu) as /devices/virtual/input/input10
[    5.184354] rc rc1: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 1
[    5.184364] usb 1-2.3: dvb_usb_v2: schedule remote query interval to 400 msecs
[    5.195747] usb 1-2.3: dvb_usb_v2: 'Astrometa DVB-T2' successfully initialized and connected
[    5.195876] usbcore: registered new interface driver dvb_usb_rtl28xxu
[   16.909302] usb 1-2.3: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000..862000000)

any help will be much appreciated!

The Panasonic demodulator is used for the T2 part, but this still doesn’t work properly yet on the Vero 4K. I’m still working on this.


ok, thanks Sam, but in this case I bought it for nothing as I assumed it would work on Vero4K.

I’ll revert to my DVB-T previous adapter as the OSMC one doesn’t even find all the channels that >?my original one did (is there another reason for only finding the few channels I mentioned in my original post?).

In regards to the Panasonic demodulator, is there an ETA for this one?


No firm ETA, but we are working on it. I will let you know when I have something to test.

Nothing obvious springs to mind, but make sure the signal is OK and the region settings are configured correctly.


Strange, I would have expected that the other channels worked like they do on my older Realtek DVB-T only adapter.

This suggest even the 1st DVB-T adapter seen within the OSMC tuner is not working properly as I only can ever a few DVB-T channels with that one.

They should do.

Have you tried re-scanning? When did you last use the old adapter?


I just re-installed it now and everything works as before.

On the OSMC one the muxes don’t scan. Tried from clean config and everything but nothing.

I’ll do a w_scan with both adapter and send you the results.

Make sure you stop TVHeadend first
And best to start Vero 4K from a cold boot when changing adapters.

yeap did both :wink: cheers.

This is the w_scan of the non-osmc DVB-T adapter that works fine:

This is the w_scan of the osmc DVB-T2 adapter that only finds a few channels and fails to scan the rest:

Also by using the configuration of tv-headend that I have with the scanned channels of the working adapter I can watch the few discovered channels on the OSMC adapter but I have no signal on the rest of the channel.

If I insert my original working adapter all channels work.

The -T side of things is the same tuner (RTL2832U) so I would have expected the same results.

I’d suggest waiting for T2 support, which can handle the latter and DVB-C as well.

When possible, use a good antenna (such as a roof aerial).


That’s the weird thing, I use the same antenna (root aerial) and i plugin the exact same cable, but the OSMC adapter is doing something different because it doesn’t scan the frequencies/find signals the same way like I also would have expected.

That’s odd. The DVB-T side works well here, and I can get all the Freeview channels I’d expect to get.
Are you using it in the same USB port as the other tuner? You could try it on another device to rule out a hardware issue in the interim.

Yes same usb port, same aerial cable everything smae except the USB tuner.

I’ll try using it on windows, but I’ve never done that before so I’ll have to do some research.

A scan though suggest there is something wrong the the HW I think, as you say it should be no different from the other one I have, else I can’t explain it.

Indeed – we can swap this out for you and test it here, but it would be ideal to test it on another machine.

Is there a windows driver for the OSMC DVB-T2 tuner?

Are you using any kind of aerial splitter? I’ve found the OSMC stick is a smidgeon less sensitive than my other (August T210) one. On some days (depends on the weather) it works fine when it’s the only thing plugged into the aerial but a little touchy with the TV plugged in in parallel.

I am actually. I’ll remove it and test it again.


I just removed the splitter same issue with the cable plugged into directly into the aerial. If it is too sensitive than clearly this won’t work for me.

I think I’ll need to return this.

I found a DVB-T2 adapter which I purchased a couple of years ago that I could never get to work as DVB-T2 but I remembered used to work fine as DVB-T.

I just found it, I plugged it in and it turns out it’s the exact same adapter/chip I just purchasd on the OSMC store, it is detected the exact same way:
Astrometa DVB-T2
Realtek RTL2832 (DVB-T)

would it be ok to return the OSMC one that I believe is also faulty and get a refund please?

Whenever the DVB-T2 issue is resolved I’m guessing the DVB-T2 bit will work for the adapter I have as well if it’s detected as above as it should be exactly the same.