OSMC DVB-T2 Adapter not appearing as DVB-T2, Can't Find Channels

You’re more than welcome to return the dongle. I will test it upon receipt and check if it is indeed faulty. Regardless of whether there’s an issue, we can certainly issue you with a refund.

Fortunately I was able to work on DVB today and I’m now happy to say that support has been added for DVB-T2 for the OSMC dongle. This gives you Freeview HD in the UK. If you’d like to try this before returning, do let me know.

You may be able to use your other dongle for DVB-T2, but we can’t guarantee this compatibility with other devices. There are thousands of devices out there; but we will do our best to support other chips.

Development was for the OSMC dongle in mind. It would be interesting to see how you get on using this device. If you do keep the device I can raise a credit on your account towards a future order.



Sam’s latest vero4k kernel is working with DVB-T2 for me here, now. You might like to try it - the dongle you have may or may not be identical to the OSMC one.

To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

To get the panasonic tuner working, delete all the files in /home/osmc/.hts/tvheadend/input/linuxdvb/adapters/ then sudo systemctl restart tvheadend.

In the TVH webui enable the Panasonic tuner (and only that tuner) and attach your local network to it. Force scan then map the new (T2) channels.

Health warning: previous versions of this kernel had an effect on IR remotes. We are doing some more tests tonight.


I can see three adapters now, 2x panasonic which I’m using and 1x Realtek.

Panasonic DVB-T adapter plays channel that I had previously discovered.

I’m however not sure how to add DVB-C channels, I tried adding frequency from here but still no HD channels discovered.

DVB-C is cable. You want to select the Panasonic DVB-T tuner for Freeview HD / DVB-T2 in the UK.

I think the only cable provider in the UK is Virgin, and unencrypted channels are only available in some areas (legacy from NTL IIRC).


Even weirder. Since the latest kernel update I can now get the panasonic adapters as I mentioned but only on my NON-OSMC older stick and not on the OSMC one.

When using the Panasonic DVB-T I can scan the usual regular channel but there is no HD channel in sight.

So in short, there seems to be something odd with the OSMC stick, however even my older DVB-T2 stick (which I’m fairly confident has the same chips as the OSMC one) can’t find HD channels. :sweat:

Unless I’m somehow hoping to find HD channels named as such and I’m just getting channels that don’t have HD in the channel or as watermark.

Go to My OSMC → Logs with the stick and post the URL here. It should let us see what’s going on.

As always, we can swap the unit over or refund.

Channel services in UK are presently dodgy, see [HowTo] Retune TVHeadend DVB for UK Freeview digital switchover.

I assume you have ran these scans without anything attached to the USB (could be power issues)


It does look to me like your OSMC stick is faulty, but here are a few things you should know.

As the 700MHz clearance programme goes through, it is almost impossible to find out what frequencies (channels) your transmitter will be using from time to time. The powers that be assume you will just let your TV re-scan the whole spectrum.

w_scan does re-scan the whole spectrum so should pick up all the transmissions in your area. TVHeadend does not do a full scan by default, it just picks up the ‘channels’ put out on each mux. Because of the difficulty of finding information, I suspect it will be a long time before the pre-defined networks in the TVH database match the real world. Hence the need to use the method in the HowTo Sam linked, or use w_scan. If you do use w_scan, you will still have to manually transcribe the mux details into TVH, probably just the frequencies.

It will not be obvious which mux is carrying T2 (HD) channels in the TVH webui. You will never see ‘T2’ appearing anywhere unless you drill down to the mux details. If you are not getting HD channels, it’s possible they have re-used a mux frequency previously used for SD in your area so TVH is using the wrong signal parameters. I’ve added what a HD mux should look like in the HowTo.

If you still can’t get HD, screenshot your TVH muxes screen and PM me your address/postcode.

I’m still struggling to find out which frequencies you should be receiving. I think your signal comes from Guildford, right? (Your aerial should be pointing south).

Can you do a retune of your TV and just note down which “channel” number (or frequency) is showing when the list of “services” (aka channels!) gets loads added to it. Guildford used to transmit channels 40,43,46.48,49 and 52 but from your screenshot 48, 52 and 49 have gone, replaced with 32,34,42 and 45.

If your TV is HD, you should be able to see which channel/frequency is showing when the HD services are added. They will be called BBC1 HD etc. They used to be on channel 40 (626MHz) but I suspect they have moved to 32 or 34 and that’s the problem.


did you see my private message?
This is my last scan http://paste.osmc.io/atipiwuweb.vhdl

Yes the signal is Guildford I looked up the frequency online before and you are right should be 626Mhz but that’s also used for SD. I tried changing to DVB-T2 but it fails to scan I might be not be changing all relevant settings.


I did retune my TV but although 1080p doesn’t have DVB-T2 built in tuner, it’s almost 10 years old.

I’ve also managed to get the Panasonic tuner to show up, but no HD channels are being scanned unfortunately. Will try Sam’s How To method shortly

Yes, but I was still guessing a bit because the on-line apps need a full postcode and street address.

Edit: with some more poking around, I have found the horse’s mouth on current channels. Use the coverage checker at DigitalUK Everyone TV | Championing Free TV for All and tick the Detailed view box or leave that unticked and drill down to Manual retuning. This will tell you the channels but not the frequencies. Wikipedia has the frequencies Television channel frequencies - Wikipedia

From that, it seems you are getting your signals from Hannington (your aerial should be pointing west), and HD services are on channel 39 (618MHz) which w_scan has failed to recognise. Try adding a new mux in TVH like this:

If that doesn’t work, you may have a signal strength issue.

@grahamh, before seeing your reply with the new frequency, I tried all the frequencies w_scan sort of partially detected and I found two of them that work with DVB-T2 settings as per How_to settings you and Sam already mentioned:

I have found 3x DVB-T2 Muxes with HD channels:

  1. 617833000Hz
  2. 745833000Hz
  3. 753833000Hz

I tried using 618167000 Hz and it detected the same channels as 617833000 however it didn’t seem to report correct the service channel number.

Considering that 617833000 is what w_scan detected and that 618167000 was not detected as well as channel service number was not fully detected I’m going to stick with the two frequencies in my previous channel list.

I now have a total of 21 out of 22 DVB-T2 channels mapped.

@grahamh thank you very much for your help and for pointing me towards the right direction. The links you posted above also clear things out a bit and I am receving on channel 39 615.25-621.25Mhz which is what comes up with my exact address.

Congratulations and good sleuthing! Yes, it’s impossible to find out which sideband of 618MHz +/- 167kHz is actually being used from the web. ukfree.tv reports +167kHz but that’s the old frequency.

746MHz is COM7 for those lucky BBC4 watchers who can get it.


I will return this on Monday, fairly sure it’s faulty, and I’m sure the one I have has the same chip so a refund is much appreciated. Thanks a lot for sorting out support for DVB-T2 on vero so promptly, works perfectly.

I found an additional DVB-T2 frequency (753833000Hz) while looking for Cbeebies HD, so I edited my previous post to include the DVB-T2 frequencies I get in the Guildford area.

These are all the Muxes I’m now using:

@nirvana80 Does it make it a difference, if you do a bulk edit of all muxes, set

  • Bandwidth to 8 Mhz
  • PLP ID to 0

but all other fields to AUTO?
The OSMC stick should support this and for German DVB-T2 this works great. Would mean a lot of things which can be neglected and you only have to care about possible frequencies.
A complete list of all possible frequencies (in theory) should give the predefined mux template “–Generic–: auto-Default” you can find in your network config. But using this means to bulk edit all these muxes to use DVB-T2, 8 MHz and PLP ID 0.

Why would that help? In UK, most of the muxes are DVB-T. Many of us can only get one DVB-T2 mux which broadcasts HD (1080p) streams. @nirvana80 is lucky to live where he can get 3 DVB-T2 muxes.

yes it works with all other fields set to AUTO with the exception for “delivery system” which needs to be set to “DVB-T2”

1 Like


I received @nirvana80’s hardware back today.

There’s nothing wrong with the dongle; however it seems we’ve accidentally sent out our 2nd generation OSMC tuner in advance. This uses a Sony based demodulator instead of a Panasonic one, which explains why you would have experienced issues!

I’ve refunded your original payment method as per your request.