OSMC error updating

I have been trying to get my system updated since April. I keep getting the message of an error. The error is rbp2-image-4.9.29-5-osmc (5). I have tried to ssh into the box and do manual update with apt-get dist_upgrade and that doesn’t work either

I have uploaded the logs to https://paste.osmc.tv/ oyoratisav


Jun 19 07:51:20 LivvingRoom avahi-daemon[246]: Invalid response packet from host


12:39:22.658 T:1307571184   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://'
                                            unix_err:'71' error : 'No route to host'
12:39:24.720 T:1959133184   ERROR: GetDirectory - Error getting smb://
12:39:24.721 T:1959133184   ERROR: CGUIDialogFileBrowser::GetDirectory(smb:// failed

You seem to be having some sort of network error, I would check you network equipment; cabling, switches and router.

Thanks Tom.

Possibly because of a network problem, which Tom has noted, the kernel package seems to have been corrupted when being downloaded.

You can check if this is the case by running the command:

md5sum /var/cache/apt/archives/rbp2-image-4.9.29-5-osmc_5_armhf.deb

It should return a value of 716dd1d3837dfe06504e170ea21d800e

If it’s corrupted, one way to resolve this is:

sudo rm /var/cache/apt/archives/rbp2-image-4.9.29-5-osmc_5_armhf.deb
sudo apt-get update
sudo apt-get dist-upgrade

I have got the same error but it occur in /etc/kernel/postinst.d/apt-auto-removal-osmc

So I edit and add after the set -x, exit 0

Then I complete the dist-upgrade, and remove the exit 0

After rebooting, I remove the old kernel

sudo dpkg --purge rbp2-image-4.4.27-9-osmc

Wouldn’t be the same error.
The change to include apt-auto-removal is new, please paste the full error details