OSMC fails to boot on Vero 4K+, even when reinstalled

Hello! I have a Vero 4K+ and I came home from a trip to find that OSMC was no longer appearing on my TV, with only a “No Input” screen. (I have updates turned off, so this was not caused by a recent update to OSMC or the underlying Linux distro–should have still been running Kodi v18.9 or thereabouts). Rebooting the Vero didn’t seem to solve the issue, though every few boots I could get it to show a screen with the “can’t execute “sbin/splash_early” : Exec format error” message instead of the No Input message from my TV.

Reinstalling the latest version of OSMC from a known working SD card seemed to work – that is, the installation went through its process just fine – but when finished, I’d get the same “No Input” or Exec format error. I don’t believe I can get any logs, because I can’t even get it to boot. (I did see it boot to the home screen once for about half a second, then it went back to “No Input”.) The device doesn’t show up on my network either.

Has the internal storage on my device kicked the bucket? I’m open to any troubleshooting recommendations I haven’t tried yet, but from what I’ve seen on the forum this combination of issues seems to point to dead device.

Hi @WhitsonGordon

Good to hear from you. I was actually looking you up yesterday to see if you’d returned to a role where we could send you a Vero V review unit after your excellent Lifehacker review in the past.

Unfortunately you seem to work for ASUS now, so we bricked it.

I jest.

That’s an odd one.

If you’re updating from such an old version of OSMC, there could be some issues (with reinstalling).

My suggestions are:

  • Try install an older version of OSMC, such as this v18.9 version here: https://download.osmc.tv/installers/diskimages/OSMC_TGT_vero3_20201023.img.gz. You can download this file and select Custom Image in the OSMC installer.
  • Try another installation medium.
  • Check the installer is actually running. You should see a warning about how the device will be formatted in 60 seconds and a countdown, and an install.log should be saved to the SD or USB you used to image the device.
  • If you’re not seeing that installer screen, show me a screenshot of the contents of the SD / USB

Hope you are keeping well.



:rofl::rofl::rofl: sorryyyy! Good to see you too Sam! Happy to hear Vero V has been selling so well. You deserve it, this is still the best box on the market as far as I’m concerned.

I’ll try an older version tonight and let you know how it goes. Regarding point #3/4, I definitely saw that the installer was running, I was watching it like a hawk to make sure it actually went through the process and didn’t reboot after the 60 second warning (since I’d seen that happen in the past). We’ll see how installing v18.9 goes, and I’ll try another SD card just in case. Stay tuned!

Okay, you know what, I think this one’s on me.

I reinstalled using the image you provided, but this time I made sure to unplug everything from the Vero — which I should have done last night — and I think my USB DVD drive may have been causing the problem. No idea how, but the thing boots fine when it’s unplugged, and doesn’t boot when it’s plugged in. A mystery, but an unimportant one, as I rarely use that drive anymore.

Just goes to show to anyone reading this in the future: FOLLOW THE INSTRUCTIONS AND UNPLUG EVERYTHING. You think “eh it’s fine,” but it might in fact not be fine :smiley: I knew better, and yet I was still too stubborn/lazy to troubleshoot properly. Don’t be like me.

Sorry to clutter up your forum, Sam :wink: I’ll follow up if anything changes but if things are still looking good in 24 hours I’ll mark this one solved.

Is it bus powered? If so, then the PSU for your Vero may be getting a bit out of spec.

Yeah, it’s bus powered. It’s worked fine for years but yeah the PSU could be having problems. Oh well, like I said, I almost never use it anyway. That’s why I have the Vero to begin with – no discs! And if I run into problems in the future…I’ll be sure to take another look at the power supply.

(I did try my second Vero’s power supply yesterday and it didn’t seem to solve the problem, but who knows.)

Alright folks, guess I spoke too soon. While I was able to get OSMC installed, it still doesn’t seem to be stable. When browsing my library, the device will crash back to that “No Input screen” (so far it’s happened twice in the past hour). Could indeed be the power supply as darwindesign was mentioning. Going to try again with my other Vero’s power supply and see if I experience the same problems…I’ll report back.


Keep us posted

Three days with no issues, looks like it was indeed the power supply! Replaced it and we’re up and running again. Thanks everyone!


Glad to hear this.