OSMC first impressions on Pi 3

Right. I thought I’d give OSMC a try coming from OpenElec for half a year.
Main reason for OSMC was more nerdy control and more frequent updates.
My first ‘out of the box’ impressions. No need for SSH yet…

OSMC 2016.10-2

  1. Installation went fine on my SD card. (Is there no easy way for multiboot OSMC/OpenElec on a single SD, with no partition sharing?)

  2. Recognizing my HifiBerry Digi+ went fine. (First activate overlay in My OSMC!).

  3. Mouse (Air Mouse) control I don’t like, yet. Almost impossible to navigate through vertical lists! Far too sensitive. Strange unintuitive behaviour, below or above middle… Never seen that before.

  4. I have an Edimax Wifi dongle in the Pi and OSMC shows my 2.4GHz network on both dongle and Pi-internal, though which is which? wlan0 and wlan1? Does the wlan# indicate the hardware, internal/external?
    It does see my 5GHz network on the Edimax but doesn’t react at all on a click? Region and band issue with my router?
    For 2.4 GHz when I choose MyNetwork (wlan1) it always connects to MyNetwork (wlan0). Huh?

  5. It doesn’t browse my Synology NFS shares yet. Maybe my bad, on my NAS security/firewall (I also just changed most all my DHCP fixed mac assignments to something logical…). Ah yep, port forwarding on the router needed to catch up of course.
    Ok, I can now browse OSMC to my NAS NFS share, but it won’t enter into subfolders or content…

  6. All ADD-ON’s so far give “Installation failed”??

  7. The App Store in My OSMC does nothing when clicked??

  8. My USB wireless keyboard was not recognized at one time. Reboot solved that.

  9. Settings > Profiles = nothing clickable, weird.

  10. My intention is to get VNC working, hopefully without SSH but that’s unlikely, shows Google.

NFS issues, Wifi issues, horrible mouse, no add-ons, no OSMC App Store.

Giving up for now. To be continued.

Use NOOBS

Tried another skin?

Disable the internal adapter. Swarch the forum for how to do this.

Probably need to add source first. You’re probably trying to browse from the Add Source list.

Log needed.

See above.

Hotplugging USB devices is not guaranteed to work.

If you actually would like your problems solved. You should read the Docs first. Also be sure to read the FAQ. VNC will come to the App Store natively later.

Thanks for all the feedback! I didn’t intend to be negative but on rereading my post I can see how it could be read. I’ll try to be more constructive in my wording.
Hopefully my pretty run-of-the-mill experience that I’ll share here, from a tech savvy but impatient user, will be helpful to others. For me, whenever I need to go SSH is a sign that things are still not mature and can be improved. I can do SSH and basic Linux, but I hate it when I have to, it’s such a hassle to remember…

Regarding multiboot, this was very helpful: NOOBS-partitioning-explained

Noobs multiboot with OSMC / OpenElec LibreElec will be the first challenge.

VNC natively will be a great feature!

I missed OpenElec in the Noobs boot.
This was enlightening: https://forum.libreelec.tv/thread-990.html

It appears that LibreElec is the way to go (coming from OpenElec), for now.
And there was OSMC!

When you have OSMC, why would one even need LE/OE is what I don’t understand.

That is what I hope to discover…

Noobs install went fine. Boot OSMC and initial wizard went fine. Connect Wifi fine (only 2.4 GHz).
First, update OSMC, from 2016.10-1 to 2016.10-2, then reboot.

Now into My OSMC > Pi Config.
Enable my HifiBerry Digi+ overlay gives: “Warning: GPIO remote support with default pins incompatible with HifiBer…” (cut off and no message scroll?). Hmm, “Enable LIRC GPIO support” is enabled by default. Google “OSMC LIRC”. Ah, that’s for a Infrared remote receiver, which I don’t have connected for the moment. So disable that I suppose.

Is there no wiki walk-through for all the Pi Config settings? That would save a lot of Googling.
IMHO settings should always explain themselves onscreen.

Reboot. Check the Digi+ works. Mute TV-sound, receiver on… And oh yes, choose Kodi audio output device of course. Yes, sound on my receiver!

Switching skin to Confluence gives a :frowning: Third attempt works. ???

its nice and all with this “review” but please pick a OS and stick with it cause we seen enough of these OSMC vs *elec threads to last us for a lifetime, we all have our own reasons for running the mediacenters and we made our choice.

as for your sad face as its been said for bugs there is a demand for debug logs or else your issue didnt happen :slight_smile:

1 Like

Now to try to get on the 5GHz network wih the Edimax USB dongle.
First disable the internal Pi 3 Wifi adapter.
Search of the forum gives two obscure suggestions:

First this one, with no explanation of what it exactly does (perhaps more than I want?),

and a second option, blacklisting the drivers for the onboard Broadcom wifi as per over in the RaspberryPi forum

/etc/modprobe.d/raspi-blacklist.conf

#wifi
blacklist brcmfmac
blacklist brcmutil

Let’s see which works. Can I edit this comfortably from the My OSMC Pi Config Editor? Let’s try the blacklist option first, as I understand what it will do. Hmm, strange editor. And is this config.txt just for OSMC, or SDcard wide, so also for LibreElec? Well, I can soon find out now I have my Noobs multiboot…

Nope. The blacklist option doesn’t work. The onboard Wifi is still there.

I thought maybe switch back to OSMC skin for better editor experience, but that was a mistake. Now when I get into the editor and select a line, the edit or delete dialogue appears in the darkened background! Behind the config.txt lines! Ouch. Why not simply Nano, which everyone wil get along with, instead of this prehistoric attempt at a text editor?

Okay, better get back to Confluence and try the other method (dtoverlay=sdhost)…
Oooh, switching skins immediately gives really weird often corrupted results, better reboot every time… (I can imagine, but it should suggest or force that).

Yep, that second option (dtoverlay=sdhost) worked. Now there’s only one 2.4GHz plus my 5GHz. And clicking on the 5GHz even allows me to connect!

So summarizing:

Start situation:
Pi 3 with OSMC and Edimax USB Wifi dongle.
OSMC lists both onboard and Edimax 2.4GHz plus the Edimax 5GHz. wlan number is arbitrary? and not physical?
Whichever wlan 2.4GHz I choose it will change to the other wlan.
Choosing 5GHz does nothing, clicking does nothing.

First attempt to disable onboard Wifi with blacklist in OSMC config editor is to no avail.

Second attempt with quick and dirty solution in (dtoverlay=sdhost) DOES work.

Now to be seen how stable the Edimax 5GHz is. Any issues will be in a separate thread if here at all.

I booted to LibreElec and it still shows both 2.4GHz plus the 5GHz networks.
Lesson learned: Pi config is OS specific. Separate for every OS on your SD.

A plus for LibreElec: it simply allowed me to connect with my 5GHz without uncomfortable config editing, in contrast to OSMC (see my previous post on this thread).

A big plus for OSMC: it allows me to set the HifiBerry Digi overlay from the GUI (graphical user interface) without any config editing, allowing me to choose my Digi+ in the Kodi Audio settings.

Until now I don’t see any major mind blasting difference. Could you give me the three most important reasons for choosing OSMC in a nutshell?

Are both OSMC and LibreElec not simply thin shells around Kodi?

I was with one (OpenElec). And it went away.

I’ll get round to uploading debug logs when I’ve bitten through the first hurdles on my own. I’m not intending to waste my time on debugging software I simply want to use, out of the box… RTFM is so prehistoric. Any software that calls itself ‘stable’ should be self documenting and work OOTB for 95%.

been using OSMC for the better parts of 2 years seldom had any issues that i couldnt resolve myself and those times that i had to resolve it via help Sam Nazarko has always been around to fix my issues.

its all about knowing Debian and for those that actually use a real OS and not a busybox knows that its all about RTFM :wink:

[quote=“SaintNick, post:12, topic:20109, full:true”]Are both OSMC and LibreElec not simply thin shells around Kodi?
[/quote]
LibreELEC is a thin shell around Kodi, OSMC is a thick shell around Kodi. OSMC is a full Debian derivative OS under the hood so you can use it for other things as well as simply driving Kodi

You can edit the dtoverlay=sdhost option in the Config Editor. If you wish to blacklist the modules, it must go in a different file.

Just for the loaded OS if you are running NOOBS.

Can you upload a log? This has been covered in the Wiki.

You can use nano to edit files. This is explained in the Wiki. You can use vim, emacs or whatever editor you like. You can also login via WinSCP and edit it from your PC. But in your first post you said you didn’t want to have to use SSH or the command line. A lot of our users come from Windows backgrounds and don’t know how to use nano

I understand that this is new to you: in the new My OSMC we will add some more features, like disabling internal WiFi, but this is low on the list of priorities. A lot of your questions are answered on the Wiki.

If you do choose to use OSMC as your daily driver, you should install it from osmc.tv/download. NOOBS is great for trying several OS, but it’s not good once you know what you want (as you’ll want to use the full size of your SD card).

This is also covered in the Wiki.

Now I see the problem. Nice try, but that’s the lazy way out. We’ve spent time preparing resources to help newcomers. If you don’t read them, you will be confused. OSMC is based on Debian, which is quite expandable (you have 40,000 packages you can install from the command line). Depending on what you want to do, you’re always going to read around the subject.

The more people bother to read the Wiki, the more likely we are to expand it. But if you have suggestions, you can improve it. Just click the ‘Make this page better’. I haven’t had a lot of time to work on the Wiki lately.

Haha. I deserved that.

Right, I’m heading over to the wiki for a simple walkthrough on installing VNC. Will be back…

I’m back already.
Wiki search for “VNC” gives “No results” :frowning:
Next option, dig into the forum, hope I don’t catch unnecessarily old/depricated results…
I remember for OpenElec it was not too difficult (client version was important!)

Search VNC on the forum

Other bits and bobs are on the Wiki

I’ll agree that our onboarding for the less familiar sucks. I’m working on improving that.

Sam

To save you from disaster

https://discourse.osmc.tv/search?context=topic&context_id=20109&q=%5Bhow%20to%5D%20%20%20vnc&skip_context=true