Osmc flicker

Any one come a cross smiliar issue?

TV (sony, model:KD-55x9000c)

(epson projector LS-10000)

I tried a fresh install but the issue presist,

It would be more useful if you would also advise what device this is and the details of your setup.

Vero 4K with latest update, after the fresh install its directly connected to the TV


Have you tried a different hdmi cable?

Thanks Tom.

Yes I have

Model of your TV could be useful information too, I guess.

Does it exhibit this behavior constantly? Or certain times of day? While playing media as well or just in menus?

It happens with both, it started to act this only the past couple of days, it was working fine before

Is the device hot? What is the temp in the room where it’s located?

Is there a way from the command kine to know that?

Room is not hot tho

Well first, just touch it. Second, it should be available in the system info screen below settings.

cat /sys/class/thermal/thermal_zone0/temp

61000 is what im getting, i will disconnect power for tonight n see what happens tomrrow

How long is the HDMI cable?
Enable HPD lock under Display settings and reboot

1.8 meter, tried two otger cables and its still doing the same thing

Its not hot, i also powered it off since yesterday, turned it back on and its still doing the same thing, I think the unit is busted

Very unlikely. It would either work or it wouldn’t work.

Please upload some logs when this happens.
Did you try the HPD suggestion?
Have you tried another display?

Tried HPD but still doing the same thing


I rebooted and did it again, logs just in case


When you tried a different display did it go directly to the display or through an AVR?

Are you using the official PSU?

Any USB drives attached?

The logs don’t show any disconnections that I can see.

You can always try the latest version of OSMC, but I can’t think of any regressions that would cause this.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.