OSMC forgets audio settings


i have OSMC (updatet to 2022 Version) running on Raspberry PI4 4GB.
My Audio is a bluetooth speaker. So, to get it running, i have to go to “MyOSMC”, there in ‘Bluetooth’ reconnect the (previously paired) Bluetooth speaker. Then exit MyOSMC,
select in Kodi System-Settings-audio-Bluetooth …
It is working until i switch off OSMC. When i start it again, i have to do the procedure
(MyOSMC /Bluetooth/reconnect… Kodi/System/Settings/Audio) again.
How i can make OSMC to remember the last audio setting?

Thanks in advance

OSMC/Kodi remembers your last audio setting. Your problem seems that your bluetooth speakers are not automatically reconnect.
You could try to pair/trust them to see if that helps.

1 Like

Thanks, but that didn’t help.
Here is what i did:

[bluetooth]# pair 5A:5A:5A:A6:08:6E
Attempting to pair with 5A:5A:5A:A6:08:6E
Failed to pair: org.bluez.Error.AlreadyExists
[bluetooth]# trust 5A:5A:5A:A6:08:6E
Changing 5A:5A:5A:A6:08:6E trust succeeded
[bluetooth]# connect 5A:5A:5A:A6:08:6E
Attempting to connect to 5A:5A:5A:A6:08:6E
[CHG] Device 5A:5A:5A:A6:08:6E Connected: yes
Connection successful
[CHG] Device 5A:5A:5A:A6:08:6E ServicesResolved: yes

So it connects and i can select it in Kodi/Audio.

But after a restart all is gone (except the ‘paired’)

In RaspiOs (Linux 5.10.103-v/+ --Buster) with Kodi 18.7 it works …

I see that OSMC kernel is Linux 5.10.78-5. Maybe that is the reason (?)

Edit 2:

After repeated crashes playing TV (Tvheadend) i think i will stop playing with OSMC.
Maybe it is too early after the update.

I will return in a few months :slight_smile:

The kernel version won’t be the cause of the issue.

Without providing logs, it’s hard to speculate what the issue is.

As things stand, if your BT device isn’t connected when Kodi starts Kodi doesn’t know it’s there so can’t initiate a connection. I think it’s the same if you shut down your phone when it’s connected to a BT speaker. If not, we can look at getting Kodi to reconnect on start-up.

After booting the Pi, if you turn off your speaker and turn it on again, it will search for devices which trust it and connect to the Pi. Then you are good to go. This assumes that your speaker hasn’t connected to something else while the Pi was off.

If there’s nothing else for the speaker to do when the Pi is off, why leave it on? Just start the Pi, then the speaker and it will will work.

Edit: I just checked. When I turn my phone on I have to re-start BT but it does then connect to the device that it was connected to when I turned it off. So if that’s what people expect, we can have a look at that.

ok, but please, provide logs the next time. I’ll append some instructions in case this is not known.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot: