OSMC freezes / locks up


I am using a RPi B 512MB version. For the last couple of weeks, OSMC locks up to the point I can not use any type of remote to control it. The only way I can get it to work is, to SSH in and reboot. Therefore, I just SSH’ed in and grabbed the latest logs, which are here:


It is a freshly installed copy of OSMC with very few add-on installed. I am using a Samsung SD 8GB card. It is hardwired to the wireless router with a 30 foot cable.

When it does lock up, it can be during music playback (which is what happened with the current set of logs), video playback and even when trying to navigate the menu. I have also experienced the lock up after having the RPi sitting overnight and coming back the next morning and nothing but a frozen screen.

If you have any thoughts it would be great. Also, I would be happy to supply any details for you that I haven’t provided. I am here to help get this issue solved.

I am extremely grateful for the OSMC team in providing the software which I have been using for years (going back to RaspBMC) and hope to be back up and running soon. Thanks in advance for the help.

EDIT: I have noticed the CPU usage is in the 90-100% range constantly. Maybe that is what is wrong?

It would be good to get full logs.
You can use grab-logs -A

If only kodi crashes, you can try sudo service mediacenter restart

Whoops, sorry about that! I thought I grabbed the logs. It is my first time working with logs, so will come back with a new link later.

Here is a new set of logs; sorry about the problem before! I hope I did it right this time!


OSMC froze while playing music.

Strange. Still no kodi log in there.

If measuring this from the Kodi menu, it can be ignored. CPU cycles are being used to constantly redraw the CPU meter.

We are aware of some freezes, particularly pertinent on old Pi. We’re looking in to the problem

Sam, Thank for the thoughts. I will still try to get the logs uploaded.

After several attempts to get a good set of logs, I think I have succeeded.


I am still having the original problem from the first post, but this last time (with the logs I just posted), the screen went black and the music stopped. Normally the Confluence Skin screen is just frozen. Again, if you need more detail from me, ask away!


I am experiencing the same issues on my RPi B.
I’ll try to gather some info next time it hangs.

– edit –
Just happened again, halfway through a movie.
Here’s the logs:

This time I was still able to ping the RPi, but connecting via ssh just hung:

debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
osmc@’s password:
debug3: packet_send2: adding 64 (len 54 padlen 10 extra_pad 64)
debug2: we sent a password packet, wait for reply
debug1: Authentication succeeded (password).
Authenticated to ([]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.

and then nothing until I pulled the plug and rebooted the hard way.

I’ll see if I can activate sysstat to gather some more info the next time.

I’m having this problem relatively often. If I scroll through the items in the TV shows too fast, it freezes (no buffer, doesn’t come back on line). You don’t have to reboot, just ssh to it, the do sudo systemctl restart mediacenter. After a few seconds it’s working fine again.

This is being worked on. Follow OSMC Freezing Missing Banners Thumbnails unresponsive UI current + Krypton versions RPi1 2 3 - #77 by popcornmix for progress.

Great! Thanks! Actually, it is just Kodi that freezes of course. I can still ssh to the pi and do everything I want. Also, sickrage and sabnzbd keep performing normally.