OSMC Freezing Missing Banners Thumbnails unresponsive UI current + Krypton versions RPi1 2 3

@popcornmix @sam_nazarko

I have started this post because @ActionA decided to close the thread we were all using to investigate the freezing issues we are experiencing as discussed in this thread April update causes System freezes - #181 by sam_nazarko even though the issue is not resolved inthe current and Krypton builds and the issues I am experiencing and it seems many others are as described by the OP @Sir_Mc_Tod in that thread. The thread seemed to latterly focus on SMB server releated issues. I do not believe this is the issue. My builds do not serve any content merely consume it, I assume using the SMB Client as all my media is on a NAS server and is shared with the network as a number of SMB shares. All favours of client consume this media, mostly Rpi 1 B+ and latterly Rpi 2 & 3, but also Android and Ubuntu Clients running current Kodi Versions. There are no issues related to these issues with clients other than the Rpi.

As a description of the symptoms, OSMC works perfectly for a while (there seems to be no consistent time when it exhibits the problem) when navigating the UI or after playing media and then returning to the TV show or Movie browser banners/thumbnails are not displayed. Sometimes the UI remains navigable for a short while but no thumbnails or banners are visible. Other times OSMC is frozen and unresponsive. SSH’ing in and either:
sudo systemctl restart mediacenter
or
sudo reboot now

Will return OSMC to fully working again until this issue repeats. This is exactly as described in the previous post by the OP in this thread April update causes System freezes - #181 by sam_nazarko which contains logs and various testing cycles from users. SO if you have these issue then please read the previous post first then contribute here. If your issue IS NOT related to OSMC freezing and missing thumbnails banners unresponsive UI then please don’t post here or we will have another thread closed incorrectly!

I have tested: (see my posts in previous thread)

Stock Rpi1 B+ running the latest OSMC (No addons etc.)
Rpi1 B+ Krypton builds (see http://forum.kodi.tv/showthread.php?tid=265306&page=1)
As above with our standard addons etc.
All exhibit the problem.

2 Likes

It’s important to get information post-crash, and it may give us clues. If you’re still able to SSH in to the device to issue the reboot command, that may be helpful.

When this next happens, can you try issuing the following commands:

dmesg | paste-log
paste-log /home/osmc/.kodi/temp/kodi.log

And then posting the logs.

There was a report of an out of memory issue. This would explain the Kodi crash, and if systemd was unable to kill Kodi, then this would also explain the hanging on the screen. It would also be good to know if you can get Kodi running reliably again without rebooting, by issuing the following command:

sudo systemctl restart mediacenter

I will check with @popcornmix if anything can be grabbed from the VC side which may give us clues as to what’s going on.

I think closing the other thread wasn’t the worst idea. We had a lot of noise there and it was hard to keep track of things. If the problem truly is the same across all devices, then we only need to work closely with one or two users to fix it for everyone.

@sam_nazarko Thanks Sam but as we previously investigated and I reported the OOM didn’t seem to be the issue. I don’t think OSMC crashes as I can SSH in and restart the mediacenter most if not all of the time certainly recently all of the time.

OK!

Is there a command to capture the logs you require to disk for sanitising before uploading?

Cheers
Spart

You can edit the Kodi log manually then paste-log it. I doubt dmesg will have anything sensitive in it, but you can do dmesg > spart_dmesg, edit accordingly and paste-log afterwards.

Please try downloading these debug versions of the Pi firmware:

sudo wget https://github.com/raspberrypi/firmware/raw/611d798ada7d36e4f4252459d55da5713b24853f/boot/start_db.elf -O /boot/start_db.elf
sudo wget https://github.com/raspberrypi/firmware/raw/611d798ada7d36e4f4252459d55da5713b24853f/boot/fixup_db.dat -O /boot/fixup_dat.elf

Edit /boot/config.txt.

Change

start_x=1

to

start_file=start_db.elf
fixup_file=fixup_db.dat

Reboot.

Run the following command immediately:

sudo vcgencmd set_logging_level=2147483648

Post crash, please run these two commands in addition to the ones which retrieve Kodi logs and dmesg. There should be no need to sanitisise these:

sudo vcdbg log assert | paste-log
sudo vcdbg log msg | paste-log

Wilco. testing on a a Pi1 B+ running 083 Krypton build.

Just crashed as I was looking at doing the above. The last lines are:

19:37:12 60968.222656 T:3026313216 NOTICE: VideoPlayer: finished waiting
19:37:14 60970.269531 T:3026313216 ERROR: GetDirectory - Error getting videodb://tvshows/titles/
19:37:14 60970.277344 T:3026313216 ERROR: CGUIMediaWindow::GetDirectory(videodb://tvshows/titles/) failed

Will implement your testing instructions now.

Cheers
Spart

@sam_nazarko

After making changes and rebooting. I get this:

osmc@osmc:~$ sudo vcgencmd set_logging_level=2147483648
error=1 error_msg=“Command not registered”

tailing log I get lots of these errors:

19:41:49 81.778992 T:2742846448 NOTICE: Previous line repeats 1 times.
19:41:49 81.779320 T:2742846448 ERROR: COMXCoreComponent::WaitForEvent OMX.broadcom.image_decode wait event 0x00000003 timeout 1000
19:41:49 81.779533 T:2742846448 ERROR: COMXTexture::Decode WaitForEvent:OMX_EventPortSettingsChanged failed (80001011)
19:41:49 81.779701 T:2742846448 NOTICE: DecodeJpegToTexture: unable to decode to texture special://masterprofile/Thumbnails/2/2a5ea635.jpg 360x540
19:42:09 102.016205 T:2786362352 NOTICE: script.grab.fanart: Grab Fanart Service Started

OSMC is NOT working as it should. No thumbnails are displayed and no TV show banners from booting up. UI responsive but nothing plays and OSMC freexes when trying to play anything.

Last entries in log:

19:45:57 330.571411 T:3025850368 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
19:45:58 330.718933 T:2557469680 NOTICE: Creating InputStream
19:45:59 331.646057 T:2557469680 NOTICE: Creating Demuxer
19:45:59 332.535492 T:3005215728 ERROR: ActiveAE::FlushEngine - failed to flush
19:46:05 337.741211 T:3005215728 ERROR: ActiveAE::InitSink - failed to init
19:46:05 337.907745 T:3005215728 WARNING: CActiveAE::StateMachine - signal: 10 from port: OutputControlPort not handled for state: 1

UPDATE

After following your changes above the pi is unstable and OSMC is unusable. I has to revert back to startx=1 and comment out the load firmware lines to get a working system back!

Cheers
Spart

Hi

I’m not sure if the debug firmware includes the codecs. It should do – I’ll talk to @popcornmix

Sam

OK. in the meantime problem appeared again: This is the end of the log.

23:17:25 12308.167969 T:2553046000 ERROR: COMXCoreComponent::WaitForEvent OMX.broadcom.image_decode wait event 0x00000003 timeout 1000
23:17:25 12308.167969 T:2553046000 ERROR: COMXTexture::Decode WaitForEvent:OMX_EventPortSettingsChanged failed (80001011)
23:17:25 12308.168945 T:2553046000 NOTICE: DecodeJpegToTexture: unable to decode to texture special://masterprofile/Thumbnails/1/160df601.jpg 758x140
23:17:26 12309.187500 T:2520773616 ERROR: COMXCoreComponent::WaitForOutputDone OMX.broadcom.egl_render wait event timeout
23:17:26 12309.188477 T:2520773616 ERROR: COMXTexture::Decode m_omx_egl_render.WaitForOutputDone result(0x80001011)
23:17:26 12309.188477 T:2520773616 NOTICE: DecodeJpegToTexture: unable to decode to texture special://masterprofile/Thumbnails/5/5da8473c.jpg 758x140

It all seems to be related to decoding and rendering jpegs.

Playing anything from the menus results in:
23:20:50 12513.150391 T:3005215728 ERROR: ActiveAE::FlushEngine - failed to flush
23:20:55 12518.152344 T:3005215728 ERROR: ActiveAE::InitSink - failed to init
23:20:55 12518.153320 T:3005215728 WARNING: CActiveAE::StateMachine - signal: 10 from port: OutputControlPort not handled for state: 1

Then we are into restarting mediacenter etc.
Cheers
Spart

Please give us full logs, and what was asked previously. We need more than snippets

Did that work?

When we hit OpenMAX errors it quickly becomes out of my knowledge, but the key is to get as many clues as possible.

Have you tried installing the first version of OSMC that worked and updating each package on at a time? This was suggested in the previous thread but I’m not sure if anyone followed up with it.

Yes, it started again fine. Managed to play 2 media files before it happened again.

Clearly something fundamental has changed since April causing these issues. I will revert back to a March build and start from there.

Cheers
Spart

I am very happy that you created a new thread about this. It seems my english isnt as good as i thought it was :wink:
Just as an update from my side.
With the Actions i last described (and the May update) I was able to reduce the frequency of freezes from twice a Day to once a week.
Usage Profile is
Up time 24/7
Idle 18-20 hours a Day
Mainly video playback (from a nas via nfs, mysql database on nas)

So:

  • Once this error occurs, restarting Kodi brings your system to a usable state.

Does it crash again more quickly after the restart? Do you still get OMX errors on the next crash?

Sam

@sam_nazarko It freezes in just the same way each time.

As an aside in order for me to test builds faster. I have a large media collection on the NAS and I have been installing from scratch then rsyncing the userdata folder over from a backup so that I get the thumbnails etc. populated.

Can you confirm which folders in userdata should be rsynced to achieve this otherwise it takes forever for kodi to sync the thumbnails etc.

Cheers
Spart

You’re not really meant to transfer Thumbnails over. I used to keep a network mount with SQL but this was dissuaded against.

~/.kodi/userdata/Thumbnails should be what you’re after.

Sam

@sam_nazarko But what about the DB files?

Cheers
Spart

If you were previously using Krypton and you are now iterating through builds, the Database will have been upgraded.

Sorry Sam should have been clearer. I meant things like Textures13.db

Cheers
Spart

@popcornmix @sam_nazarko OK i have been testing a build compiled on the 22nd Feb 2016. There are no symptoms present. Navigation is fine thumbnails.Banners etc. display correctly. No freezing. This uses the same addons skins etc as our normal builds. Mythtv Client for Live TV.

This was built from scratch then booted once. Thumbnails and Textures13.db and userdata xml files were rsynced from a backup so that it would connect to our mysql server and have all thumbnails locally and not take forever to re-fetch them.

where do we go from here?

Cheers
Spart

Hi

It’s good you’ve found a version that is working well

I will follow up shortly on how to upgrade each component until we find the culprit

Sam

Hi

Thanks for your feedback so far. It’s appreciated.

I had a chat with @popcornmix. Let’s try updating firmware first. You can update to the firmware that’s in the latest version of OSMC by following these commands:

sudo -s
wget https://github.com/raspberrypi/firmware/raw/611d798ada7d36e4f4252459d55da5713b24853f/boot/start_x.elf -O /boot/start_x.elf
sudo reboot

I’d like it if you could run your device for 24 hours, assuming the bug normally presents within 24 hours, and then report back. Then we’ll try the kernel. Then we can move on to Kodi. Failing that – system libs…

1 Like