OSMC going black after installing files and booting

My Pi 4 4GB had been running libreelec while there wasn’t an available version of OSMC for it. When it came, I decided to uninstall libreelec and install OSMC. However, it didn’t work. I get the rainbow screen, followed by the ‘formatting device’ progress bar and then ‘installing files’ one. After these two however, the device reboots, gives the M logo and then just goes black. If I hard reset it just does the same thing. When I tried libreelec again, both directly and with NOOBS, it didn’t work either. Is this an OSMC issue or Pi? It worked fine before. Please help, thanks.

(first time on the forum my apologies for anything missed out)

If you can login via SSH I’d suggest uploading some logs. If you experience the problem with other operating systems then it’s unlikely to be an OSMC issue.

I’m sorry I don’t see how I’d login via SSH… OSMC crashes before it loads the menu and I don’t know the IP address because it doesn’t connect to the internet before it crashes, but you are right that it is probably a Pi issue and not OSMC.
oh and before the M logo it says on a black screen,
waiting for root filesystem device
recovering journal
{something that disappears too quickly for me to read}

Seems like the same issue I’m having with a Pi3B