OSMC Initial Release for ATV1, Installation Help Thread

Sam, has just released the first version of OSMC for the Original Apple TV !

For those who are installing this, I would like to point out the following:

  • Installation on USB device ONLY is currently possible
  • When creating the USB installation tool, you will notice that the device type selections are greyed out. This is intentional. Those options only work for non ATV devices.
  • Installers will work for Linux, OSX, and Windows.
  • USB install will not affect an existing internal Hard Drive installation.

There has been suggestions to use an unsupported app called “ApplePi Baker” to manually create the stick on OSX, This is not recommended because it can cause the partitions to be damaged. Use the official installer instead.

Important: There has been some issues in the previous test version caused by slow, or incompatible memory sticks.
If you run into a problem, try another stick first. If you still run into problems, post your questions here.

Time to install and give some feedback everyone !

General OSMC documention is available on the “General” Section of the wiki:

ATV Specific Documentaion can be found in the ATV Section of the Wiki:

Please check the documentation before posting a question.

POST LAST UPDATED Nov 23, 2015 7:00 am GMT

2 Likes

For those who have a WORKING USB please post your installation details.
Exact stick/card+adapter used, Audio+video configuration, Hub, etc.
This will help others when choosing which hardware to use.

My Install for example:

Installer Version: Windows installer on Windows 7
Device Used: Lexar MicroSD adapter and a Class 10 Lexar MicroSD Card.
USB Hub: Generic unpowered hub, with only BT and USB sticks plugged in.
TV connection: HDMI 1080p
Audio Connection: HDMI to surround sound. I had to change audio settings in Kodi to HDMI 5.1 audio passthrough. HDMI non passthrough worked, but not for HD Youtube streams.
USB Bluetooth Adapter : Generic “Cambridge Silicon Radio”
Bluetooth Keyboard: BK3001 Cheap Chinese “Apple Appearance” Keyboard. Keymap is lacking. ESC key isn’t recognized.


I am on OSX9.5

OSMC installer does not give options for atv1.

qt-host-installer is version 118

Where are actual instructions on how to install?!

Please re-read Spinner’s post above.

I responded to your other post: OSMC arrives for original Apple TV - #4 by sam_nazarko

Sam

please remind me, can i use atv1 for аn old tv which has only composite in?
so the old analog standard, this cable:

Hi Sam,

Many thanks for releasing this. I know the ATV1 is very old and perhaps has a limited user base that may make it hard to justify putting in the time and effort, but it is indeed appreciated.

I have a question in relation to HDD installs. I know you said this isn’t available, but I’m curious about your reply to toib’s post in the other ATV1 thread:

toibs:
Can we not just install the image onto HDD, and expand the partition to fill the entire disk - Would that not work???

.

sam_nazarko:
Yep, that’ll work if you’re comfortable with doing that manually. Be sure to modify com.apple.Boot.plist and /etc/fstab

Are there any pointers you can provide to get this working on the HDD? Perhaps some keywords so that we can search for articles on how to do this? Or a brief overview so that we can manualy figure out what’s required (I’m happy to write a how-to - as inelegant as an automated HDD installer, I’m sure a lot of users would be grateful for any ability to run off the HDD even if manual steps are required)?

Thanks!


Looks like it might be possible. See http://quixventure.com/2011/12/crystalbuntu-installation-guide-part-2-preparing-the-thumb-drive/ for information on modifying the xorg.conf file in Crystalbuntu to enable composite output.

Not sure if this will work for OSMC though.

1 Like

Component cables will work, but you will need to edit /etc/X11/Xorg.conf to get this working properly.

1 Like

will give it a try. want to give the atv1 to my parents, so they could watch detective series online))

Sam, i need composite. the old format.

Yes please! HDD install pointers would be awesome! And thanks for keeping atv alive after all these years!

Composite will work fine, you just connect one video cable to the green output, and will need to configure for 480/576i.

1 Like

Hi Sam!

Thank you for all your work and for OSMC for Apple TV 1Gen.

I appreciate your work very much. Also the ecological aspect is very important for me.
Apple TV 1Gen. is a really “good piece of hardware”, it simply “throw away” would be a “shame”.

I also use my Apple TV with Component output ( HDMI is broken).

Sam, what is the best way to edit the Xorg, can you give here an Example for Xorg with Component output.

Thank you for your help!

Regards
orionics

I have the same problem as test release:
Install failed; could not mount bootfs
Disk created via windows. Apple TV booted from usb flash drive without internal hard disk.

I’m interested too in HDD install pointers, I guess we just have to attach the drive to the computer, install and resize the partition but I would like to know which and how we have to modify the .plist files to boot from the HDD.

Maybe anoher option is to share a cloned .dmg with a clean install with the modified files so we can restore it to the HDD.

Thanks!

I’m also encountering the same error on an ATV without an internal HD. But on my other ATV with an internal HD, with the exact same USB stick, the install proceeded fine. Is the installer looking for an internal HD?

It would probably be much easier for someone to take the existing installer (which has 99% of the work done), and just add the missing piece: hfsprogs for mkfs support. Then the partitioner will work properly on the internal disk. I will get this done when I have more free time, but for now an initial release was important.

That bug should have been fixed last night, and should not be present in the 16th November or 17th November images. I would need to set netcat output to verify what the issue is.

Sam

Hi

Please see the new Wiki section I have just created for Apple TV:

Sam

1 Like

Hmmm my Patriot USB freezes at last stage of the progress bar. I’ve seen some users having this issue aswell. You need netcat logs to debug it right ?