OSMC install issue on USB Stick


I read many topics on this installation mode but none can help me.
I’m actually trying to install OSMC on an usb stick.

I’m using :

  • Raspberry PI 2 B
  • PNY microSD Card : 8Go
  • Sandisk Usb stick : 32Go

I read many topics and site to find how to install it properly :

  • I flashed usb & sd card (FAT32)
  • I used OSMC installer on the SD Card using “On USB Stick” option.
  • I inserted sd card & usb stick on the raspberry and launched it.

But the splash screen remains (the colorful one) and nothing happens as if it doesn’t boot and try to install. I thought i came from my usb card, i changed for another one and same result.

No logs on the SD Card , nothing to help me. Do u have any idea ?

Thanks in advance.

Have you choosen the right image?
Are you sure you have a Pi2? Post a picture!

Image used : OSMC_TGT_rbp2_20180316.img.gz (downloaded by the installer)
Rasp used : Raspberry PI 2 Model B V1.1 (wrote on the rasp board)

Colorful screen :

I meant a picture of the Raspberry Board

hmm i’m going to think u doubt about my reading skill, but ok, i didnt understand :stuck_out_tongue:

Well over the years we had more than a handful of cases that people got this wrong, so it’s always best to see a picture.

Next step try a different SD Card.

hmmm … i had to sacrifice a 64Go SDCard from camera but the installation starts well.

I just bought this SD Card, the last one was KO. :confused:
Is OSMC or raspberry selective about SD Card type ?

This SD is visible on W10.

I’ll change it next week :frowning:

hmmm, i saw the screen and turn off my rasp (when it says 60sec left to before install on usb stick.
I re-turn on the rasp after i plugged my keyboard. Same screen than before.

I decided to reset the install on the SD and restart from the beginning : same error now.
This 2nd card is still visible on W10.

OK, I think I found the issue. It may come from my SD Card reader. It’s an external usb dock (multi card reader). I changed with the first SD Card on a native card reader (notebook) and the installation is occurring.

Thanks for your ideas fzinken. It helped me a lot !