OSMC_Installer Error

I just re-downloaded the OSMC installer (windows 10 on Surface Pro 3) opted for the 09 version of the OSMC for RPi2/3 and set to install to a 64 GB Sandisk Ultra SD. I’ve used the installer before on this computer and had no problems writing older images for RPi2 to a 64gb SD card.

After downloading and extracting the OSMC_Installer says it’s encountered an error and to read the log file. First, I have no idea where the logfile is on the installer, and couldn’t see any reference to it in the wiki (I accept I may just be being blind).

I then tried a different SD card, did an h2testw on the card and tried re-downloading and extracting the images. All brought the same error.

I finally used win32disk imager, which copied my downloaded 09 image to the card fine, and it has installed and run no problems.

Is there any obvious reason for a problem with the installer?

Are you running the installer as admin?

  • Check write protect switch
  • Don’t run the installer off the SD card
  • Check AV software isn’t scanning.

These are the usual issues. The log is in your user directory, called osmc_installer_log.txt.