OSMC installs, then fails to boot with a kernal panic

This is my first attempt at building a RPi system. At the time of error the entire build was these parts:

Raspberry Pi 2 Model B Project Board - 1GB RAM - 900 MHz Quad-Core CPU

SD card is a samsung EVO 16gb

It failed to booth both with and without the ethernet cable plugged in. It has failed to boot with and without a keyboard or mouse plugged in. I used SD Formaater 4.0 to format the SD card and I have installed OSMC with it using both the self-executing file or by directly mounting the image to the disk.

I get the same error in every instance: “Kernel Panic - not syncing: No init found… blah blah init.txt”

Is there some way I can capture some boot data to post here?

Thanks in advance for the help.

Which image did you use?

2015.10-1 (for RPi 2)

Any reason you are imaging the card manually instead of using the installer?

I tried using an imager after the installer had led me to this error originally. I was hoping it was a problem with the installer. Apparently, it is not.

You need to confirm that your pi is actually a Pi2.

edit: the board says Model 2 B V1.1 right on the PCB

Openelec works with all my peripherals. I guess it’s a OSMC issue then.

It’s apparently only an issue for you… Did you try a different power supply or uSD card?