OSMC is broken if installed form NOOBS

SUBJECT: to make it work you should install OSMC via NOOBS and then hook up SD card to a Linux PC and edit or create few files

  1. add this to /etc/fstab in root partition - it is important to fix the updates. (otherwise it is empty)
    /dev/mmcblk0p6 /boot vfat defaults,noatime,noauto,x-systemd.automount 0 0

  2. replace or createif missing /boot/cmdline.txt with this in boot partition - it has wrong (/dev/mmcblk0p2) partition by default (which is correct one if OSMC installed not via PINN but wrong if installed via PINN).

    root=/dev/mmcblk0p7 rootfstype=ext4 rootwait quiet osmcdev=rbp2

I’ve got the reply from raspberry forum that partition_setup.sh is broken and should be adjusted by OSMC in order to work out of the box.

Can you link me to the thread on the Pi forum?


Thank you.

I’m not sure what PINN is, but it seems to be a customised version of NOOBS.

I made some changes to how OSMC’s partitioning is handled. We know use PARTUUID based labels. We’ve done this because of some upcoming changes to NOOBS and we’ve been told to add support for this.

Since putting the change live on Friday, I haven’t heard of any failed installations. Can you confirm if this issue is indeed present with the official version of NOOBS?



It will take me a few days to confirm since i am out of free SD cards :smiley:
Just ordered a new one. but i wont’ be able to pick it up tomorrow. I will definitely try with NOOBS and PINN on Wednesday 12.04.2017 and confirm where it works and where it fails.

I’ve replied to the issue here:

So I’m sure we’ll get this resolved soon. Thanks for bringing it to my attention


1 Like

Can you try a fresh installation now and let me know if it succeeds?


I’ve tried installing osmc and raspbian using NOOBS and osmc still doesn’t load. I’ve noticed that the /etc/fstab folder is missing.
I’m trying to dual boot my pi like another one i have. Is there a fix I’m missing?
I used the network install of noobs lite.


Haven’t heard of any issues in the last few weeks.
Are you using the latest version of NOOBS?


I believe so. I downloaded it from raspberrypi.org. Version 2.4

I tried raspbian and libreelect also, and libreelect didn’t load either. However, raspbian seems to load fine.
I’ll try again.


Try a different SD card.

That’s weird.
I’ve done installation from PINN (but i should be quite similar to noobs if not the same) less than a week ago and everything worked as expected…