OSMC is freezing

Hi there,

I’ve just installed OSMC on my Raspberry Pi 3 but I cannot play any media located on my network drives on Windows 10 or on the SD Card.

This part below is not really relevant but it might be interesting too:

First of all, I wanted to mount with SMB but I keep having the same message “Operation not permitted”.

I’ve seen countless threads with this problem and I’ve tried a lot of manipulations, no luck from now. It seems that Samba is now restricted, and I tried to change with protocol v1, v2 and nothing relevant appeared. (it’s working perfectly with my Galaxy S7 and Es Explorer, and another computer on Windows 10, so it’s probably a bug in OSMC).

So, I’ve decided to change how I access my network shares, so with SSH I have mounted them with:

sudo mount -t cifs //\ Matthieu Series\ Matthieu/


I can now access to them in console or GUI but when the playback start, well the screen just stops! To be sure, I have copied directly on the SD card (Sandisk Ultra class 10) some files, with various size and codecs (SD, 720p, h264) and it still freezing :frowning_face:

I have uploaded some logs here:

When I start playing, and if I connect with SSH and execute top, I can see that the CPU is around 6% for a good old It Crowd (180 MB file). One more thing, I am streaming audio to my Bluetooth Speakers because the Video Output is a DLP projector without sound.

I have reverted to “standard” profile, no turbo mode: same thing.

Any help would be greatly appreaciated :slight_smile:

This means those devices are not up to date, and vulnerable from attacks such as WannaCry.

Regarding the freezing: can you still ssh in? How are you powering the Pi?

It does not look like you have the codecs for the Pi. I’d guess that’s your problem.

H264 should still play though

I made a clean install, so if it’s not included by default, it’s probably the issue.

What’s the mediainfo on the file you are trying to play?

Did you pay for the codecs? If so, I thought that they were permanent now.

Yes I have access with SSH, and I bought a power plug on Amazon (Aukru Raspberry Pi 3 Alimentation 5V 3000mA)

No I did not. But it does freeze for every video that I have tried.

It’s not a debug log so hard to speculate