OSMC keeps dropping internet connection every few minutes

OSMC keeps dropping internet connection every few minutes.
I have a wired connection and all appears to be fine with network showing as connected but after a minute or two it shows that the internet is busy then it says not connected check network settings then it reconnects and it starts over again!
I had OSMC working beautifully for months and it never gave cause for concern. Having read about the security problems that needed dealing with so I decided to upgrade to the latest version and have not been able to use it since.
I have tried to find similar problems but there doesn’t seem to be any that have been particularly relevant.
Any advice would be appreciated.

I doubt that problem to be related to the recent update. Suggest to:

  1. Check your ethernet cable and your switch (restart)
  2. Check your powersupply and cable
  3. Enable Debugging and upload logs

Any specific logs?

Where are you checking the internet connection ? If it says “internet is busy” I assume you’re looking in System Info->Network ?

Do you have an actual internet connection problem, eg you can’t play a video stream or update addons, or is it just the message above you’re concerned about ?

If so, don’t use that as your guideline of whether it’s connected or not, as that Network Information screen is known to be incorrect sometimes.

A better indication would be in My OSMC → Network. An even better indication would be to log in via SSH (if you can) and trying pinging a server on the internet.

I cannot play anything! A stream will start and within a couple of minutes it will buffer and drop out. All connections are as they were before when all was working perfectly. My OSMC Network shows that it is connected. I can SSH in to the pi but how do I ping a server from there?

I may have, never done this before, uploaded all the log files to: http://paste.osmc.io/luyorfomu

ping www.google.com

Yes I can ping www.google.com

Any packet loss pinging What latency are you getting?

Between 39.8ms & 42.5ms.
Strange things happening. Yesterday evening the internet connection stabilised without me doing anything at all! This morning on “system information” it showed that the internet was connected, however, when I checked the status on My OSMC Network it showed no connection. At the moment it appears to be working okay even with these odd occurrences. There is an OSMC update available and I will install it later with some degree of trepidation.

More strange things. Both yesterday morning and this morning I have a screen asking if I want to install the available update but the RPi is frozen and I have had to ssh to reboot! Until now OSMC has worked like a dream so I am going to start again with a fresh install tomorrow.