OSMC kills my Pi

I ran the OSMC installer and it seemed to install just fine to USB. However when I put the usb stick and memory card into the Pi and turn the Pi on, I get nothing but the red light on the Pi and nothing on the screen(no signal). So I took a known working OSMC installation and put it in the same Pi it works fine. How do i tell which version of OSMC I am running. I have tried all of the ones on the installer list and none of them work. I have three Pi’s and all do the same thing, except for the known working install that i have.

  1. The installer will only install the basic boot loader to the SD card. The installation to the USB stick only happens after initial boot from the PI. Therefore ensure that you choose the SD card device when you run the installer.
  2. Make sure that you have the right version PI1 or PI2 installed. Therefore first figure out which PI (Hardware) you have and choose the respective image.

See this article for a bit of explanation: http://www.averagemanvsraspberrypi.com/2015/10/install-osmc-on-a-usb-stick.html

Sam