OSMC/Kodi Crash

After Upgrading to OSMC 2020 01-1 OSMC crashes after booting: when the Kodi screen comes up and I select an item in the left hand pane OSMC crashes. Workaround is: after booting doing ssh and stop tvheadend (sudo systemctl stop tvheadend). Wait for a few seconds and restarting tvheadend. Then I can select the items in the lefthand pane without OSMC crashing. With the previous OSMC version I had sometimes crashes after watching TV and going back to the lefthand pane and selecting any item.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

My guess would be a corrupt EPG or TV guide.

Try clearing the EPG cache under Settings.

https://paste.osmc.tv/jenisemono

After debug enable OSMC crashes while booting. Tried several times ond finally succeded. Stopped the tvheadend (otherwise OSMC crashes immediately). Disabled debug and removed the TV-Stick, then reboot and Upload the log.

Did you try clearing the EPG cache?

Dont know how to clear the cache. I removed the .db file in userdata and .hts

Go to settings, live tv and clear data under general & guide.

Ahh, yes - I did it serveral times before. Tried it again and after watching TV going to lefthand pane in Kodi selecting the item above TV: crash

Your log doesn’t show a crash. Can you re-upload?

I think you will not see a crash. Because “crash” means: the OS (Debian) is crashing, there is no program who could write what has happened. The Monitor goes black, no keyboard/mouse interaction.

Hi,

I suspect its only kodi crashing, rather than the whole OS. Can you ssh in?

If so please try and reproduce then upload logs:

$ grab-logs -A

If not, please reinstall:

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Thanks Tom.

No, I cannot ssh - its not only Kodi, its the OS! I thought first that it is a Hardware Problem, but without tvheadend running everything is OK.

It might be power-related. TV sticks should ideally be attached to a powered USB hub.

I tried already with a usb hub. things doesnt change.

Its a Hardware-Problem!!! Moved the Vero on top of the desk - peng, crash. Whenever I move the Vero it crashes. Removed the TV-Stick from the USB-Port: No crash, can move/shake the Vero

You mean when the TV stick is directly attached to the Vero4K?

OK, got it: its the 1st USB-Port. No difference via Hub or directly attached.
I have put the TV-Stick in the 2nd USB-Port: no crash anymore.
Checked the 1st USB-Port: its very slick - dont know if that is the right english word

Another good argument for using a hub, to protect the ports on the Vero itself.

TV tuners are power hungry and it sounds like your tuner is not receiving enough power. A powered hub should solve your issue.

Problem solved! to clarify: it was my usb disk connected via a usb hub. I changed the usb hub and everything works.