OSMC + Kodi on Raspberry Pi3 with Android / Apple Remote App works only with internet conncetion

Hello :slight_smile:

I googled and searched this and other forums for a long time before this post. I also tried many many things. So please don’t think I’m just lazy. I didn’t find a solution or any other person with my problem. So I hope there’s someone who could and would help me - Thank You very much in advance:

A few days ago I bought a (my first) Raspberry (Pi3)

My goals:

  • use it as a music player, so I also got a HiFiBerryDigi+
  • select (not stream) the music with a smart phone/ pad (means control the raspi without an extra screen)

So, no problem… after a few minutes I had

  • OpenElec/ Kodi up an running
  • Different Kodi Remote Apps working as I wanted with a Android smartphone and also iPad

Great? Kind of…

I try to make it as short as I can:

Setup:
Raspberry connected via cable to a switch, which is connected via cable with a FritzBox(AVM) Router (=internet connection)
I also have a WLAN Router connected to the same switch mentioned above

The Raspberry can use the internet connection with the cable attached.
The Raspberry can use the internet connection of the WLAN Router (no LAN cable attached).

The Remote Apps can communicate with the Raspberry via it’s built in WiFi when:

  • the Raspberry is connceted to the switch via WLAN Router (=internet)
    and / OR
  • the Raspberry is connected to the switch via cable (=internet)

But:
The Remote Apps can NOT connect to the Raspberry when I remove the cable AND switch off the WLAN Router

Sorry for this long explanation, but if I just write: “Remote Apps not working without internet” I’m afraid to get too many questions/ hints that won’t help me :slight_smile:

Then I switched to OSMC with excactly the same problems. I tried static IP/ tethering and every possible network configuration with the built in tools.

Then, as a final try I used SSH via Windows to do some connman configurations.

I tried static WLAN IP

I tried this (post 6/7)

but no luck.

Well, now I also can connect to the Raspberry configured as a HotSpot, but STILL ONLY if it’s connected to the internet :grimacing:

I couldn’t try the last post from here
http://stackoverflow.com/questions/31943490/how-to-set-static-ip-address-using-connman-for-wifi-network
because I wasn’t allowed to get there (I mean the mentioned folder)

What am I doing wrong? A general mistake? So many hours for nothing really :confused:

I want to take this RaspberryHifi Thing to my friends, hook it up there and control it via RemoteApps - “just” that :cry:

Thank You for Your time :pray:

Have you tried using the apple/android device as a hotspot?

No :thinking: could it be that easy? :upside_down: Great idea - Let me try.

Uh, that was my first thought and I mean it! But I don’t know how to make it: the phone / pad communicate with the internet via the WLAN Router so I can’t simulate the App connection to the Raspberry with the WLAN Router switched off. I think about it and post the results asap.

Hello again,

your idea is a workaround, a good one, but not the final goal - I can connect the Remote App to the Raspberry without an internet connection now though.

But now I have to find out how to setup the Raspberry to always connect to this specific HotSpot and keeps polling it until the connection is done.

edit:
https://wiki.archlinux.org/index.php/Connman#Connecting_to_a_protected_access_point
search for “Connecting to an open access point” and follow the steps. The “*AO” on the “example output” tells You that OSMC will auto connect to that service if available. But only if the “*A” above that service is not reachable (in my case I had to remove the cable from the Raspberry and it connected to my HotSpot).

Anyone else with another/ more convenient solution maybe?

Not sure why this is an issue. WiFi connections made through GUI are treated this way by default.

I think there is another issue you have yet to consider in your desired configuration. If you connect the Apple/Android device to the RPI hotspot that does not have internet access to provide, the devices will also not have an internet connection.

  1. My Raspberry does not connect to the HotSpot automatically.
    edit:
    after doing the last post from this:
    http://stackoverflow.com/questions/31943490/how-to-set-static-ip-address-using-connman-for-wifi-network
    it does
  2. I would love if that would work as I don’t care about an internet connection, but as I described, the App does NOT connect to the Raspi without internet connection.

So, I still need someone who can tell me why it seems not to be possible to connect a Kodi Remote App to a Raspi which does not have an internet connection as described in my main question :confounded:

You don’t need the internet to connect most of the remote apps, but you do need the controller node and controlled node to be connected on the same wifi network so they can talk to each other.

If you disconnect both ethernet cable and wireless then there is no connection between the controller node and the controlled node and so it will fail.

For your use case I eould suggest you look at a dedicated remote like the one in the OSMC store or look for a remote app for your phone which uses bluetooth instead of the LAN.