OSMC leia 18 on rp3 - no PVR IPTV simple client available

#1

i’m trying to use IPTV on OSMC leia .
but i don’t see any link to PVR in Add-on menu .
is it gone in leia , like alot of add-ons and skins ? or i’m doing something wrong ?

do i need to install TVheadend server from Apps section in OSMC application ?

#2

tried to install via shell , but got error :slight_smile:

osmc@osmc:~$ sudo apt-get install kodi-pvr-iptvsimple
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-pvr-iptvsimple : Depends: kodi-api-pvr (= 5.2.1)
E: Unable to correct problems, you have held broken packages.

it depends on : kodi-api-pvr
so , this may imply that i need to install TVHeadend from app menu ?

#3

It’s already installed. All you have to do is go to the add-on browser, look under My add-ons and just enable it.

#4

it is not installed .
nothing in add-ons !
i tried to search for it , but no use also

#5

Go this way, in OSMC skin:

Settings -> Add-on Browser -> My Add-ons -> PVR Clients -> PVR IPTV Simple Client

and enable