OSMC.local not resolving

Hi All,

I just did a fresh install of the 2016.09.01 image.
Avahi is running and installed.


::1             osmc localhost6.localdomain6 localhost6       osmc       localhost
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters



The Device Name in Settings > Services > General is osmc

On my previous build I could use puTTy to SSH into osmc.local and use my web browser to access osmc.local:80.

But now it isn’t resolving, the DNS is not found, as below:

osmc.local’s server DNS address could not be found.

Any idea why it isn’t working?

Not from the output above. However we haven’t changed anything with Avahi for some time.

Are you using the same OS on your other device as before?

Hi Sam,

Thanks for the response.

Yep, same exact. (If you mean the laptop that is)

I had my pi running on an older version of OSMC, from a few months back. It was freezing so I did a new download and fresh install.

I haven’t changed any of the Avahi settings or anything so I have no idea why it isn’t working. Last time it worked out of the box if I remember correctly.


I was waiting for you to provide the appropriate logs to investigate this further; however I suspect this is a local / network issue as there do not seem to be any other reports.

Hi Sam,

It was working on the network, previously, but I realized we just switched our router to a new meraki x64 which I suspect is the issue.

I have managed to access RPIMonitor and SSH via osmc.local every now and then, but then it stops working again after a while.


There are my logs - sorry I hadn’t read the post about useful support requests! I assumed there might be a common solution.

Hm, I don’t know what the issue is (the logs do not load); however I’d say that if you have introduced a new router, that may well be causing the issues.

If you have an opportunity to swap back to the old one to test, it would be worth doing so to see if the problem lies with the router and if there is a configuration option you can change.