OSMC/MacOS X. SMB file sharing. Connection timeout

smbclient - command not found. SMB installed

Without seeing whether the Mac is seeing the requests there isn’t much more we can do. Everything seems fine from the OSMC side so I would suggest you also raise this on a Mac forum to see if you can find out how to get a log file out of your Mac.

sudo apt-get install smbclient

I am solved my problem with SMBUp server for OSX, works perfecrtly! As default SMB in Mac isn’t working.
smb fix

Glad you got it working.

A post was split to a new topic: DD-WRT File Sharing

Apple’s own “SMBX” implementation on OS X has been broken at various times for various reasons.
SMBUp is a workaround that goes back to OS X 10.7, and is even mentioned on the Kodi Wiki.
With OSX 10.8.2, many users were having speed problems.
With Mavericks 10.9, there was compatibility problems with some NAS storage systems, and a workaround, at least when I last looked into it, was to force SMB1 (by using CIFS:// for example).
El Capitan 10.11.5 was reported as causing a large slowdown in transfer speeds.
https://discussions.apple.com/message/30219922?start=120&tstart=0
That issue reportedly also exists in OS X Sierra.

SOME Mac users who want to use OSX shares via SMB, with other non-apple devices, resorted to installing the “Samba” version via SMBUp (which was created specifically as a workaround), but it’s not a perfect solution if you read the SMBUp FAQ.

The discussions.apple.com forums are likely the best source for a solution for whichever version of OS X someone uses, since this is usually a problem with Apple’s SMBX implementation, and not specific to OSMC and Kodi.

Personally, I gave up on SMB when I upgraded past OSX 10.6 and have used NFS since.

Why do we need additional installations? Please look at OpenElec, there it works.
With OSMC I have the same problems :frowning:

You didn’t provide a log or any description of your problem, just necromanced a thread.

OpenELEC uses an outdated, and insecure version of SMB. OSMC prefers to use a secure and stable version that is compatible with a wider range of devices. But if OpenELEC works and you’re not fussed about security (i.e. NAT), just use that. We can’t help you without the proper information from you. Pretty much all SMB issues can be solved with a quick search on this forum.

I don’t need to post logs, because they are the same… otherwise I wouldn’t have used this thread :wink:
… and I don’t want to use OpenElec ^^

No logs, no issue.

You haven’t:

  • Proved that your issue is the same as OP’s
  • Explained how you’ve tried to configure your shares, or what your actual issue is.
  • Confirmed whether using hostname or IP based resolution

I would suggest that you just use OpenELEC if you have no intention of helping us help you.

Again… why writing everything twice?
So…
I have a Raspberry PI 1 with OSMC, the newest version. I have a Macbook Pro with macOS 10.12.1. I also activated the file sharing in macOS as well only with smb share. Folder name is OTVR. Also I activated the guest account for sharing (only for sharing).
Adding the source via “browse → ZeroConf → …” brings me a “connection timed out”. Adding the source manually with the IP as well.

kodi.log says:

02:59:25 46.394066 T:2810704880 ERROR: SMBDirectory->GetDirectory: Unable to open directory : ‘smb://192.168.178.21/OTVR’
unix_err:‘6e’ error : ‘Connection timed out’
02:59:28 48.841427 T:3023401904 ERROR: GetDirectory - Error getting smb://192.168.178.21:445/OTVR/
02:59:28 48.847385 T:3023401904 ERROR: CGUIMediaWindow::GetDirectory(smb://192.168.178.21:445/OTVR/) failed

The same configuration works fine with OpenElec. But I don’t want to use OpenElec, because I can’t access my system with apt-get …

I suspect OS X is not compatible with the version of Samba we use (Samba 4.x). OpenELEC still uses Samba 3.6.

1 Like

Can I downgrade?

We never shipped Samba 3.6 in OSMC.

You would have to compile it from source, and rebuild Kodi against the new libraries. I don’t have a Mac, so I can’t investigate this further, but it’s likely an issue with authentication.

I just tried Xbian. smbstatus says: “Samba version 4.2.14-Debian”
Connecting to my macOS share works perfect without adding it manually (so with ZeroConf). Unfortunately, AirPlay doesn’t work in Xbian :smile:
But this proves, that it’s not a problem with macOS :wink:

Depending on how old that XBian image is, there were changes to Samba in Debian in April that may have caused the issue.

But both OSMC and XBian use upstream (Debian) packages for Samba. So it’s either a configuration issue or the XBian image is using an older version of Samba without the security improvements

It’s the newest Xbian image (XBian_2016.12.23_rpi). I can check the configuration for you (where?), but as I said, Xbian is using Samba 4.2.14. Is OSMC using a newer one?

Use dpkg -l to check package versions

And check your SMB config for differences on the two systems. Some tweaks to the settings may be all that’s needed

OSMC is using the same version.

On Xbian:
ii samba ... 2:4.2.14+dfsg-0+deb8u2 ... armhf ... ii samba-common ... 2:4.2.14+dfsg-0+deb8u2 ... all ... ii samba-common-bin ... 2:4.2.14+dfsg-0+deb8u2 ... armhf ... ii samba-dsdb-modules ... 2:4.2.14+dfsg-0+deb8u2 ... armhf ... ii samba-libs:armhf ... 2:4.2.14+dfsg-0+deb8u2 ... armhf ...

I also copied the smb.conf, but it’s still not working. What else can be the problem?