OSMC makes tv switch source when starting video

Hi,

I just changed from RASPMC, feels like a nice switch :smile:
But my problem is that when ever i start a video (no mather format) the tv switches to another HDMI source or TV.
I do not have anything else connected to the tv, not even a tv-signal just my Rasperry Pi 1 with OSMC on.

Using Raspmc it all worked smooth, sometimes the cec did not work to a 100% (the remote did not work in XBMC, but that was solved by a remote). I never had this, the movie starts and i end up in another source and have to manually change back every time. For me that is annoying, but the kids don’t get it.

The tv is a Samsung 7005

Have a look at Settings>System>Input Devices>Peripherals>CEC and change the options there to prevent it

Hi,

that would be an option except that I use cec to control OSMC.
Is CEC not that well working yet?

Have you actually looked at the settings dilligaf suggested ?

You do not have to disable CEC to solve your problem. Turn off the “make Kodi the active source” option which is the second option in the list.

1 Like

Hi, well I did and my problem is that Kodi is NOT the active source once starting to play movie. Do you mean it stil might fix the issue?
By preventing KODI from saying “i’m active” the tv will not switch away from kodi once a movie start?

The logic feels wrong, but that dosen’t mean it’s not right!? :smile:

Sorry, I misread your original post.

If your TV switches to the wrong HDMI input when you play this is caused by a buggy CEC implementation on your TV - you should be able to work around this by changing the “HDMI port” setting at the bottom of the CEC settings to match that port that the Pi is connected to, or change the Pi to the port that the TV is trying to switch to.

Or you can disable the option to send the active source command.

I didn’t know these options existed!
Kinda hidden in this GUI