OSMC Network file transfers (SMB + windows share)

I have overall solved my problems but would like to point out a couple of things that are not really clear and that took me some time to understand.

Distro is OSMC stable version
Hardware is RaspberryPi + HiFiBerry but not really relevant

I set out on a task to transfer some music to the external HDD connected via USB on the OSMC RsapberryPi.

  1. Installed SMB server
  2. Created a share on the Windows 7 machine
  3. Added user osmc/osmc to the share folder with read (later on read/write) rights
  4. Went into File manager and started copying files (google: kodi file manager for commands). It would finish with errors any way I tried. I even tried with individual FLAC files (20mb) and sometimes they would be copied sometimes I would get an error. Overall unusable.
  5. Tried to access my HDD via the Network in Windows but could only see the Home folder with subfolders (Movies, Music, Pictures…). Took me about an hour (must be quite tired) to understand that if you type in “my computer” address bar " \ \\ you will get also the access to root and your mounted drive in the media part. substitue the IP address with your OSMC IP address
  6. Started copying music by copy/paste via windows. Interesting thing was happening, it would be copying but at one moment it would say it is unable to continue and gave me options to “try again”, “skip” and “cancel”. Try again wasn’t working so I skipped and from time to time it would ask to choose again. After it finished with the skips included I went to check the files which are there, all of them seemed to be there. I am now listening to the music and still not getting any corrupt errors or read errors and music seems to be playing fine.
    6.1. No other program had the files locked or open so don’t think that could be the problem and it was a copy not a move.

Not sure what could be the issue or if anyone has seen it or wants to try and replicate but might be useful for other people.

Thanks to the team again for a great product! :slight_smile:

No need to attempt to replicate if you could describe the setup better and provide logs as requested in the sticky at the top of this subforum…


I don’t understand what the actual URL you are typing in to get root access.

I tried smb://“my computer” address bar " \ \ 192.168..\

It doesn’t work.

Please explain. Thank you. I’m on a Mac and I’m having the same problem (Tried to access my HDD via the Network in Windows but could only see the Home folder with subfolders (Movies, Music, Pictures…)).

Actually I figured out if you go here in Terminal:

sudo nano /etc/samba/smb.conf

You can change the [osmc]

path = /home/osmc/


path = /home

And you can now access the atv folder that is alaised/shared when adding it in videos files section on KODI.