Osmc new install not working

A Hi I am new to the pi and have installed osmc onto raspberry pi b+ But having problems
I have loaded the version for the pi 1 it runs a script after the recovery window but stops .the last 2 lines of script as follows

panic: VFS: Unable to mount root fs on unknown - block(179,2)

entering kdb (current =0xd60c8000, pid 1) due to keyboard entry

It does this even if I unplug mouse and the keyboard ( I tried this in case there was a sticky key on keyboard but the keyboard is new)

Sounds like hardware issue. Try another sdcard. If this doesn’t work, provide more detail on how you got to this point. There is no reason that an install should fail and you are the only person reporting it, so not a widespread issue affecting all new installs.

I will get another sd card tomorrow and retry ,
To get to where I am I formatted the sd card installed the latest version of noobs , 1.4.2 booted it up and connected to Internet via cat 5 cable selected osmc for pi 1 let it load and then powered pi off and rebooted hangs at same place each time . Even tried loading original noobs and re installed as above and still the same

Can you try OSMC without noobs?

Managed to get it going with a different sd card thanks