OSMC no nic connection after NFS-server remove

I was going to setup the NFS options when I got disconnected and now either a wired or wireless will connect. I ran

sudo apt-get remove rpcbind nfs-common

got the broken pipe message and now when I check the network, I have no IP at all and when I hit enable adapter, it sits there says “working” forever. Any idea what I need to do?

Why did you remove nfs-common ?

It is one of the pre-installed packages, and our network-osmc package has a dependency on it, If you have tried to un-install it it will have warned you that that package would be removed so you must have said OK to this.

This will have broken your network connection. The easiest way to fix this is to download the package and copy it onto the SD card and re-install it from there.

Pi 1 version:

Pi 2 version:

Download it on a PC then copy it to the sd card, then boot off the card. You will need a keyboard attached.

Log into a local console then run the following command, substituting the correct filename:

sudo dpkg -i /boot/filename.deb

Then reboot.

Did that work for you ?

FYI, as of the most recent updates we have made a change that now makes it impossible to accidentally cause the network-osmc package to be removed due to a dependency being removed:

yes thank you. My only issue now is, my videos are on my windows box. To steam to the pi in NFS, doesn’t the windows box need to use NFS? how is this setup?

You can use SMB, but performance may not be as good if you use a Pi 1. On a Pi 2 there is enough extra horse power than streaming high bitrate movies even over SMB is usually successful.

okay. How do I setup NFS then between a windows box? I have yet to find anything on the windows side and setup on the pi 1