Osmc not able to "see" files on local drive

I have a RapberryPi3 running OSMC (V 2018.08-2 / Kodi 17.6) with TV Headend (V 4.2.6) as it’s PVR Service. In TVHeadend the Recording System Path = /home/osmc/TV Shows. This is on a local drive.
It appears to record programmes OK and if I ssh onto the Pi I can cd to the /home/osmc/TV Shows directory and see all the recordings I expect.

However, when I go to the osmc interface on the RPi the recordings don’t show up under the “TV Shows” menu item. I can find SOME of them by choosing Videos / Files / osmcTVShows / TV Shows and then I see a two recordings out of thirteen! Note that the osmcTVShows is in a list of “Auto-mounted drives” - is this significant? The drive is local.

I tried Settings / Media /Clean library and a reboot but that didn’t make any change.

I recorded a set of logs and they are in https:/paste.osmc.tv/ogexarimog I had a look, but I don’t know what I am looking for but nothing seemed obviously like a warning or error.

Can you suggest what I should try, please?

To start the output of

$ mount

will help see where things are really being mounted. And I’m assuming you are mounting via fstab, so the contents of /etc/fstab would also help.

mount gives me …

devtmpfs on /dev type devtmpfs (rw,relatime,size=377240k,nr_inodes=94310,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mmcblk0p2 on / type ext4 (rw,relatime,stripe=1024,data=ordered)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
systemd-1 on /boot type autofs (rw,relatime,fd=31,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
/dev/sda1 on /media/WD 150G USB type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0111,dmask=0000,allow_utime=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=76472k,mode=700,uid=1000,gid=1000)

and a cat of /etc/fstab gives …

/dev/mmcblk0p1  /boot    vfat     defaults,noatime,noauto,x-systemd.automount    0   0
# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/mmcblk0p2  /    ext4      defaults,noatime    0   0

Does that help?
Anything else I can provide?

Sorry about the bold text, don’t know what happened there

I fixed your post for you, in the future, when you are pasting code bits, use the </> icon to properly format it.

So your mount tells me that you drive it mounted at /media/WD 150G USB

I see nothing linking that to /home/osmc/TV Shows or /home/osmc/osmcTVShows

How did you create the link?

I have a usb drive which is /media/WD 150G USB, but that isn’t in use - I did try at first, but it seemed to put itself into a sleep mode, so I am now using everything on a 32G SD card.
So the two are not linked.

The real path in the osmc file system is /home/osmc/TV Shows.

The reference to osmcTVShows only comes up under Videos / Files and then it shows osmcTVShows, TV Shows and WD 150G USB.

However, the one I am trying to use is /home/osmc/TV Shows.
I can access that using ssh to the operating system and see the recordings, but when I try to access it from the osmc GUI I don’t see most of the files.

So you are trying to use an SD card to record live TV? You know that that is a really bad idea as it will wear out the card fairly quickly.

Look at your video sources, did you add a osmcTVShows source?

I agree that using an SD card is a bad idea - but I got it working that way!

No I didn’t add the osmcTVShows - it came up under “Auto-mounted drives” so I am assuming that the system detected the drive and added automatically.

Your sources.xml disagrees with you:

        <path pathversion="1">/home/osmc/</path>

Clearly shows that you added a osmcTVShows source pointing to /home/osmc

I agree that the entry is there, but I don’t how it got there! It wasn’t something that I added. I know that because the osmc file system entry is /home/osmc/TV Shows - and in this case the it is spelled with a space between TV and Shows, but in the one in the sources.xml it does not have a space.
Hence the reason I think it is system generated.

Nothing is added to your sources.xml unless you do it yourself. I’d just remove it, and add a new one pointing to the proper directory (or edit that source to point to the proper directory)

OK So a bit of progress.

The way I have been navigation is using Videos - Files - TV Shows and it only let’s me see a few of the files which ARE in the directory. The other files just don’t show up!

However, if I go to Setting - File manager and navigate to the correct directory /home/osmc/TV SHows then I can see all of the files I expect. And it even lets me play them - BUT unlike the proper GUI it doesn’t remember how much I have played and so can’t restart where I left off.

So, now that I know that the files are there, how do I get them to appear in the Videos - Files - TV Shows menu ??

What does your sources.xml look like now? Did you add the appropriate directory to your library yet?