Osmc not booting

Upto last night everything was working fine. But this morning it’s not booting up and all I see is flickering on tv screen. I am running it on pi 2. Don’t want to reinstall as will lose all my settings, library, and addons.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

can you access over ssh and pull the logs from
/home/osmc/.kodi/temp

well its stuck at booting and only showing
/dev/mmcblk0p2 recovering journal.

does it mean sd card fault? the only thing happened was that my kid put the power plug to 110 instead of 220 which is usual for all my devices power.

Quite possibly resulted in filesystem corruption. You could try to fsck the partitions of your sdcard by use of another linux system.

can i do fsck on windows as i don’t have another linux system.

No, for the root partition you would need a system that can check ext4 filesystem.
So main question is what is less efforts to reinstall from scratch or trying to rescue this installation.
If you want to rescue it but only have a windows system you could boot a Live Linux (e.g. Knoppix or Ubuntu) and then do the filesystem check

If it says the above then you are already running the November kernel which includes automatic fsck on boot. Recovering journal is what fsck will do if you have had an unclean shutdown.

Are you sure it is hanging at this point ? I find that hard to believe, how long have you waited after this message appears ?

DBMandrake
well that it, it doesn’t show anything beyond that point and stays there for long time before the screen goes black and flickring starts on the tv screen.

and i did updated it few days back to latest version also via update option. so i assume its already on November update.

any solution if recovery is possible.

btw is it possible to install osmc on usb drive and then boot from usb drive and then probably check this card ?

No. It is possible to boot your windows machine with a Linux thumb drive in order to fsck the card.

how do i create linux thumb drive?

Ok instead of doing checking, I tried reinstall osmc. But when I tried to install using Windows installer it fail to write image on sd card and gives error with messy to check log file. Where is this log file placed in Windows.

Ok, this in combination with your original “not booting” issue clearly shows your SD card is broken. Get a new quality SD card and you should be up and running soon.

Assuming that you use a current OSMC installer and are using a windows version higher than Vista the log file is in C:\Users<USERNAME>\osmc_installer_log.txt