OSMC not launching on RP1

Hi guys, so I installed the following distribution on a SD card http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp1_20160130.img.gz using the regular installer http://download.osmc.tv/installers/osmc-installer.exe

But once I plug the SD card at the back of the pi and plug it, nothing displays on the screen.
The only thing I got is the red power light on the PI which turns on.
I tried with differents chargers, SD cards but still no result.
I can’t provide any logs since nothing displays on the screen.

If I can provide any more information, please let me know.


Nothing at all? That doesn’t sound good! Did you had any other distribution successfully running on this combination of RPi, power supply, HDMI cable and TV?

Also if you plug the SD card again into your windows PC what files do you see?

I bought this RPI second hand and it was running smoothly before that.
When I plug the sd card to my laptop I do see the regular files that you would see after installing osmc on it.
I will send a screenshot tonight.

Well than it looks like correctly installed. Still would suggest to try a NOOBS or Raspbian install just to if any of that boots

thanks will do.

I just tried with another sd card, installed noobs on it, everything booted up correctly on the pi.
Then I reinstalled osmc on the same sd card, works now. Thank you!