OSMC not playing bluray iso files anymore

After a reboot my OSMC is not playing any of my blu-ray ISO files.

Log file has been uploaded

You need to provide url of the log.


You may have a problem on your network such that it is not finding the computer by name. You could try putting the following in your advancedsettings.xml file (assuming this is the correct IP of your file share).


You may also need to add credentials to your passwords.xml file for that IP or instead of subing <to>smb://</to> you can sub in <to>smb://myusername:supersecretpassword@</to>

I did consider this, because all my iso files are in the same folder. However I have no problem accessing all my other media files in other folders on the same shared NAS (quark). So I put a mkv file in the folder with the iso files. When I tried to play that in OSMC it had no issues. So it is definitely an ISO problem.

Can you try playing a ISO from a drive connected directly to the Vero just to verify if this is isolated to a networking issue.

What does your passwords.xml file look like (edit out real info for user/pass)? I don’t see in your log where it is actually passing that along when it is trying to open those iso’s.

This would make the most sense as I had just added password protection to my NAS. But not sure why it won’t work only on that one file type. I do not know where to find password.xml.

I entered the password info the first time I reconnected to my share folders.

found it:

> <passwords>
>     <path>
>         <from pathversion="1">smb://quark/dvd</from>
>         <to pathversion="1">smb://user:pass@quark/dvd/SD TV/</to>
>     </path>
> </passwords>

Change it to this…

<from pathversion="1">smb://quark/</from>
<to pathversion="1">smb://user:pass@quark/</to>
1 Like

makes sense, but did not fix the issue, I uploaded a new log:


Did you reboot after you changed the file? If you did you need to check that file for any errors as i’m confident that is where you problem is. The new log still does not show the user/pass being using on the iso’s.

Yes, I did reboot, I just downloaded and rechecked the password.xml and it is the correct version. I agree with you, thought for sure this would work. I just copied an ISO to another folder on the NAS and it worked. So the problem is specific to that folder. I deleted that folder from and then re-added it, tested it and still doesn’t work.

As soon as strange things start to happen I always suggest to migrate using autofs which besides better performance will give you more troubleshooting options.

1 Like

Maybe double check the permissions for the “bd” folder on your NAS. Can you post the entire contents of your current passwords.xml file again please (with user:pass edited of course)

In the spirit of fzinkens comment above you can try this via ssh to make sure you can actually connect with the settings you are using.

sudo mkdir /mnt/bd
sudo mount -t cifs //quark/bd /mnt/bd -o user=username,vers=3

(make sure to put in your actual username and if using SMB v1 change that as well)

At this point you should get a prompt for your password and after typing that in you should not get any message back. If that went as it should then type in the following to check that your share is accessible…

ls /mnt/bd

1 Like

Thanks for the suggestions, turns out a followup firmware update issued yesterday on my NAS and now it works. Go figure. The permisions thing was driving me crazy for a whole day.

I may migrate just to alleviate any future headaches. Thanks again!

1 Like