Osmc not streaming live (tvmosaic OR mediaportal)

Not quite sure when this started to happen - its been summer and TV unused for long periods, but it seems to be after the August update. I ve a server with TBS 6698 dvbs2 quad and a DVB-t dual
using tvmosaic as backend - the tvmosaic scans and discovers channels but OMSC doesn’t play the stream. Oddly the channels from the DVB-t card DO stream albeit with a lot of pixellation.

I tried installing media portal which has a useful preview so I know the channels are scanned and play properly (at least on server - Same thing OSMC will not play a single channel.
I have tested the (wired) network connection and I am getting a very healthy speed (in anycase this is affecting 3 different boxes in same way so unlikely to be one network connection. I am running 2x Vero 4k and one Raspi
Can anyone guide me how to diagnose this further - what logs should I be enabling - can I view them myself (do they say anything a beginner like me would understand!) Am I right in thinking because media portal previews on server it must be an OSMC thing? why might the terrestrial channels play and not the Satellite?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Many thanks Sam
I cant now reproduce as I seem to have accidentally fixed it.
For the information of others :-
I was advised to reinstall the backend TVMosaic server and see if it could produce a stream - this I did but it still did not produce a stream on the server(using tvmosaic s/w) QED the problem was with TVMosaic. I borrowed a dVBs2 usb tuner thinking it might be the quad TBS card (remember the Terrestrial channels streamed ok) I deinstalled all quad tuners and installed the drivers for the USB tuner - the streaming came back but still would not stream to OSMC Kodi over the LAN.
I then deinstalled the USB and the quad tuner was now showing as ‘unknown’ so reinstalled TVMosaic =again - and quad tuners reappeared correctly - rescanned and the streams returned (on TVMosaic server only)

But OSMC-Kodi still would not stream the satellite channels . AS always one tends to throw the kitchen sink at it (deleted the databases using SSH etc etc) so I am not quite sure what corrected things but the streams reappeared soon after I switched on transcoding and got one or two channels (albeit with rubbish picture) - switched off transcoding and timeshifting and all the streaming returned on OSMC-Kodi

It is always difficult to diagnose when there are two issues hiding behind one another but I think the TVMosaic server issue was a driver issue and various reinstalls solved it
There WAS definitely an issue with KODI-OSMC not streaming the statellite channels but it has now gone away after fiddling with the transcoding/timeshifting - I am reluctant to try to recreate the problem
One thing I do notice is that the channels now take quite a long time to switch

Any comments or observations gratefully received for future reference.

Finally Sam do you think there would be any value in uploading the logs as you kindly explained? - something was going and I hate not knowing what

If everything is working now then logs aren’t needed