OSMC Not Updating

My RPi 2 isn’t wanting to update to the latest version of OSMC (stable 1.0)

When I click update, it scans, but doesn’t come back with anything. I have tried:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

All of the above were followed with a reboot, but still no joy.

I think I am running 0.9.9 (OSMC June 2015.06-1). My Kodi was compiled May 23rd 2015, and I am running Kodi 14.2.

I am reluctant to install again via SD Card, as this has worked before. Any help would be appreciated.


thats the latest version Isengard is coming soon

Thanks, so there isn’t a OSMC V1.0 Stable release then?

How soon is Isengard away? I need to consider how this will impact on my MySQL implementation.

Final was released about a month ago, Isengard is right around the corner. What do you see in the bottom left corner when you open MyOSMC?

OSMC June 2015 2015.06.1 on my RPi 2, and:
OSMC Release Candidate 3 0.9.9 on my RPi 1

Your Pi2 is the latest, I “think” your Pi1 is out of date and needs updating.

You may need to ssh into the Pi1 and run sudo apt-get update && sudo apt-get dist-upgrade

RPi 1 now updating, didnt need to log into SSH.

My second RPi 1 is massively out of date, more so than than the one that is updating (as it usually lives at my Parents house on a VPN to my network). On that note, how to I stop the OpenVPN from launching at boot-up temporarily?

I’m on PI 2 - It don’t update using the sudo apt-get update && sudo apt-get dist-upgrade

still says RC 0.9.9 - any suggestion?

What does APT say?


Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade

Does it work this time ?

Well - it downloaded a lot and installed new packages, but still it says OSMC Release Candidate Three 0.9.9 - Think I’ll need to make a clean SD card install from image