OSMC not working rpi4


So I rebooted my rpi4 lastnight and I got a sad face and no other error since then:


Any idea what is going on?

It’s impossible to tell without full logs.

I see lots of references to matrix in that log when it’s running Kodi Nexus. You might like to try reinstalling OSMC so you get the latest versions of your add-ons.

which logs do you need?

how do I reinstall osmc? Burn the iso on the sd again or there is another way?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

are you aware that I cannot get there because kodi never started? It just gave me the sad face without any menu or anything, how can I enable the debug from the cli?


For some reason, there doesn’t seem to be a how-to for Raspberry Pi in the Wiki. Just download the installer Download - OSMC run it and follow the instructions to burn an SD card with the system.

looks a bit too extreme, there is no other way to solve this? I mean, reinstall everything on every errors makes not much sense, specially since yesterday was working just fine :confused:

OK so I don’t see anything obvious affecting your add-ons since early June, but it seems just before you posted, a user gonzalo removed autofs. I don’t know what the effect of that would be without digging deeper.

Start-Date: 2023-07-13  12:59:13
Commandline: /usr/bin/apt-real purge autofs
Requested-By: gonzalo (1001)
Purge: autofs:armhf (5.1.7-1)
End-Date: 2023-07-13  12:59:18

Can you shed light on that? There’s usually only one user osmc.

kodi-send -a toggledebug

but since your crashing really early in this case you would probably need to instead

nano ~/.kodi/userdata/advancedsettings.xml

and add in the option for debug logging according to Kodi’s wiki. Although, I suspect this may be in vain as it may be more likely to be corruption on your SD card or a power issue. You might want to just try switching over to stock Kodi userdata to see if it clears up…

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

yup, I just used autofs to mount my nas, then I changed it to just use /etc/fstab and deinstall autofs, I disabled it totally and all the /home/osmc is owned by osmc, anyway, same thing (what you see on the logs)

I did the switch to a “clean” .kodi dir without luck over the same sd, I will burn a new sd with the old .kodi dir and see what happens

1 Like

well, reinstalling and moving the “.kodi” files just worked, I still don’t know what went wrong 2 days ago… thanks for the help

1 Like