OSMC Official Remote Misbehaving

Hi, so my remote has always been a bit shady - the directional controls and the OK button tend to jam but not enough to be annoying enough to do anything about. However, the other day my Vero2 crashed hard and after a relatively long fsck, got stuck in a sad-face loop. I reflashed it with the latest image from an SD card and it seems to be mostly OK (still a bit crashy, more so than last week, but that’s a different issue)

But the remote is now not behaving at all. Probably 90% of button presses are ignored and it jams buttons “on” more often than not. I’ve tried re-pairing it, I’ve tried replacing the battery. It seems to get slightly more stable if I select the “RC6 Disable” checkbox (at least I think I’m selecting it, the My OSMC controls are very hard to tell if they’re on or off), but still not stable enough to be usable.

The Vero used to live behind my TV among the forest of cables and games consoles and is currently out on a table next to the TV while I fix it, so there’s actually a slightly more clear signal path than before (although I don’t think it’s a signal issue).

OSMC is responding just fine to input via a keyboard, web interface and the Kore android app.

Any ideas for things to try to make things a little better on the remote front?

Make sure that the receiver is placed in the rear USB port. It sounds like you’ve plugged it in to the side port.

This won’t do anything – it only affects IR remotes.

Yes, it was on the side. Moving it to the back worked.