Osmc oficiall WiFi dongle has no internet connetion on 5ghz radios

Hi all,

I have just received OSMC WiFi dongle from Sam, connected it imediately and has mentioned problem.
My router(Asus rt-ac530p) has 3 radios. I can connect to each one, but internet connection works only at 2,4 GHz.

Built-in WiFi card is disabled by config file modification. Any ideas?

  • Is 2.4Ghz and 5Ghz set up as separate SSIDs (this is ideal)
  • What region are you in? Sometimes manual adjustment is needed.

Sam

Initally i had 3 radios named the same and proper band was chosen by mac adres filtering. Then i created 3 different radios and can connect quickly but No internet.

I live in Poland, router was bought in Poland, but i use Merlin firmware, perchaps it is a problem?

So you get an IP address? Can you ping the router from the device?

Yes, i get IP from The router but cant connect to Osmc via ssh.

Can you connect a keyboard and drop to the command line to check if you can ping the router.

The router might not be setting up a default gateway.

route add default gw ip-of-router

will likely resolve the problem for the user. But this really needs fixing on the network side if that’s the problem.

How can I get acces to The command line? Excuse me…i made some modifications by putty, but never tried to use command linę directly from osmc.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

In short - Choose Exit and Press Escape

It looks weird, adapter seems to be connected, led is blinking…

Unfortunately stiil No internet. I can’t get access to my movies, to Netflix, No connection via putty

P.s. I use Kodi 18 aplha

Just connected my edimax 5ghz adapter…works well.

I would bet the output of route will show no default route for a GW. A user had this problem a couple of months ago, and they were running a custom router firmware. The quick workaround was to just add route add default gw to rc.local. However after they updated their firmware, they said it wasn’t necessary anymore.

Unfortunately I can’t remember any more details.

It is possible. I experience similar problem when try to use The card with my laptop. I have to look at my router settings deeper.

Your laptop is probably easier to test with as you’ll have a keyboard right away.

If it’s a Linux laptop, you could run the route commands as suggested above.

Sam

In my experience Asus Merlin is pretty solid.

If you can SSH to the router (I think it will be admin@192.168.1.1 on Asus Merlin) a quick route -n should clarify if a default gateway exists in the routing table.

The gateway should also be visible at

Settings -> Systeminfo -> Network

Doesn’t always get registered as route however.

Sam

Hi again,

I did a plenty of different trials recetly to force OSMC dongle to work with 5ghz WiFi.
There must be one of following issue:
Unexpected compatibility problem between adapter and my router Asus rtac5300 with firmware Merlin
Or The adapter has 5 GHz radio broken.

Even on Windows devices [pc, laptop) connection of the dongle causes unstability. Computer equipped with dongle is unable to connect to my router.

Yesterday I installed a fresh copy of osmc…also No internet.
A can make ifconfig, route -n, ping to,router(takes a lot of time)
Weird things happen.

Dzień dobry.

In your first post you said:

"I can connect to each one" What does this mean? Do you get an IP address from the router on 5 GHZ, as well? The photo shows an IP address. Can you SSH to the IP address or ping the IP address on all 3 bands?

1 Like

ok guys,

it must be a hardware conflict between 5hgz radios built into my router (Asus RT-AC5300) and OSMC official adapter. I can connect do both radios but there is no internet connection available, no SMB share, no netflix and so on…

a couple minutes ago I managed anoter 5 ghz in my flat. I use own ASUS EA-AC87 in AP mode, created a new 5Ghz network called ASUS_5G, connetc via MyOSMC and it does work!
have no idea what else can provide to such a strange behavior…
same gateway, same submask

Maybe different channel?