OSMC on Pi Compute module: No Power to USB

Hey guys, I’m trying to run OSMC off my Raspberry pi. However, in order to connect… like anything to it (no internet on the chip! Whoops!), I need to use USB. However, on CM4 IO boards all USB power/IO is disabled by default. To enable it, you need to add “dtoverlay=dwc2,dr_mode=host”

however, OSMC has a dtoverlay already:

Changing that will make the screen go black after the splash screen/boot is finished (It connects via HDMI). Any idea what to do?


Which version of OSMC are you using?

Did you change this setting after OSMC installed, or did you change config.txt before the installer ran?

I changed user-config.txt after OSMC was installed. And The latest, 2022-10-1 I believe is the name. Thanks for the response.

As it’s a CM board, I assume you are a developer. Do you have a UART you can connect to in order to run some commands?


I don’t unfortunately. I got the CM board hoping it would have more oomph for a media player.

I am a developer but not for hardware or embedded lol. I’m doing all this hoping to get a SSH (Of course, I need wifi to do that, which requires a dongle, which since it’s USB needs USB power) or failing that, plug in my keyboard/mouse pair (but I need USB power for that too)

Unfortunately I don’t have a CM4. I only have various CM2-3 products around.

There’s another USB report but it’s on a more recent version, with that said, if you could try it it would be useful. I assume you’re booting from an SD card. You could boot that card on a Pi 4, dist-upgrade to the development repository and move it over and see if it helps with things


I happen to have a pi 4 laying around. I was hoping to eventually use that for octoprint though haha. If it weren’t for that, I’d just use that one for the media server. I’m still tempted even given that circumstance. How do I do the dist-upgrade business?

Can we establish which version of OSMC you are on first?


2022.10-1 for Raspberry pi 4/400

You can try the latest and greatest as follows:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Unfortunately I have no way of accessing the command line because there’s no power on the USB ports. No wifi (so no SSH) + no keyboard mouse. If we can address that, my problem is solved.

If we can install this update on the machine without use of the command line, I’d love to.

I’d suggest waiting until the update is officially released then you can install it from the Download page.

I’ll let you know when this is available.


Hey Sam,

By any chance, has there been an update that fixes this?

I discovered that you can technically have multiple dtoverlays, which ideally would power the USB, but for some reason adding the power dtoverlay didn’t do anything, at least to the config-user.txt.

Do you have any idea how I can use a uart to directly get command line access?

I would try adding them to config.txt since some things don’t work in an include file.

Hey that worked! I edited the config.txt and added the dtoverlays and was able to use my USB mouse/keyboard set.

However, I still unfortunately don’t have internet access. The wifi adapter should be supported out of the box by raspberry. I wasn’t able to use lsusb to see if it was even attached.

However, I was able to use the dmesg | grep “usb” thing to find that it was attached, just not recognized as a usb dongle. Any idea how to proceed?

EDIT: found your message when I ran sudo raspi-config xD :pray:

You could try the Kodi v20.1 test builds. They contain a newer Pi 4 (5.15) kernel which may resolve the problem.

Unfortunately I don’t have a CM based device to test with


I still don’t have a Pi 4 CM Module to test with, but suspect this is now truly resolved.

If you could confirm, that would be appreciated.