OSMC on Pi stuck since update


I have not used my Pi for a few days, I know an update for OSMC was pushed at the weekend as I can remember updating. However since the update OSMC will not load and is just stuck on the OSMC Splash screen.

I can still SSH into the Pi and logs below. Any advice would be appreciated to save me having to reformat ! (however Im a noob with linux command line) so please be friendly with commands :slightly_smiling:

I have also tried df-h and have plenty available space on SD Card. Simple reboot commands from putty and still stuck.


Thanks in advance !

Nothing obvious from your log files unfortuantely. The APT logs look fine and so does the journal. A Kodi log would have been nice to see…

You don’t use a MySQL install by any chance ? The journal shows Kodi is launching and is not crashing, that could be consistent with a MySQL install that is unable to connect to it’s server.

1 Like

Hey Thanks for the reply. Don’t use MySQL install. Sorry I could only post 3 links as a new member.

If this is not the log you need, Could you provide the shell command for Kodi pastbin log and I will post it !

I also tried (which was suggested on a previous post)
sudo systemctl enable mediacenter

Thanks again!

No sign of Kodi crashing in your logs. What sort of TV do you have connected and what resolution can it go up to ? The following command will report the current resolution:

tvservice -s

The following commands will report the modes that your TV advertises it supports:

tvservice -m CEA
tvservice -m DMT

LG TV. Full HD 1080p worked no probs until this week.

None of the tvservice commands you provided return any information via SSH. Putty just seems to stop and not return any data and does not return me back to a command line for any further input ?

I can’t think of any reason why the tvservice command would hang and not return any output.

Sounds like your install has become corrupted somehow.

I just tried apt-get update and apt-get dist-upgrade and then a reboot and same issue.

I will do a clean install and hope that will sort things out.:slightly_smiling:

Clean install performed and OSMC back up and running. Thanks for the help!

just did update via my osmc, it came up in desktop (640x480, started in 1080p)
so in settings>system>video, i set 1080p, got blackscreen:-\
bounced kodi from cli, screen came back but unresponsive to mouse/kbd:-
rebooting now…came up in 640x480
lather rinse repeat
but now responsive (killed osmc’s kodi, not root’s)
system>video still says desktop resolution, but severely overscanned
video calibration can adjust the upper left corner, but not lower right:-
bounced kodi again, this time adjusted l-r 1st, hal-lay-loo-ya!-}
h/w acceleration essential, still waiting for the key
and exiting live tv kills the picture, but the sound carries on & holds the tuner
waf = 0

I can not see the relation to this thread. If you experience an issue please open your own thread with a clear description and provide logs.

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.