OSMC on Raspberry 2B screen size problem

After a freeze of the system mine screen size gone like in the picture, resolution is correct (1920x1080)…

OSMC Kodi 18.7 on Raspberry 3B+
Can someone help me?

try this in ssh-session:

tvservice -e CEA 16 HDMI

that gives 1920x1080 @ 60Hz (CEA 31 for same resolution 50Hz, CEA 20 50Hz interlaced)

if that doesn’t fix it try fbset
and list what it says

this is fbset, with tvservice command it says that CEA is invalid argument

mode “1x1”
geometry 1 1 1 1 32
timings 0 0 0 0 0 0 0
rgba 8/16,8/8,8/0,8/24

Maybe the file config.txt is missing?
Where should be placed?

So sorry, I forgot the “”
tvservice -e "CEA 16 HDMI"

config.txt is stored here: /boot/config.txt

Command tvservice is now acceptd and ssh says "powering on HDMI with explicit settings (CEA mode 16) but the TV screen goes black but the Raspberry it’s still online but only red leds on
I find config.txt and it’s on the right location

Now i’m a bit baffled, you said this tv used to have 1080p??
please do this in ssh:

tvservice -m CEA | paste-log

that will list the modes your TV says it supports, and post that list on the web, i can read it if you post the url that comes from those commands. Remove “| paste.log” if you want to read it your self, or click on that link yourself

Here the log

Group CEA has 16 modes:
mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
(prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced
mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive
mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive
mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive
mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive

I don’t kow if helps but this problem starts after i have connected 2 Amazon Fire Sticks via lan at the Raspy, could be this the problem?

I have a hard time to belive that letting to fire sticks access the pi via lan would cause this behavior. You said the pi3 frooze and you pulled the plug and started it up again, and that is what you saw.

Have the tv been restarted? I’m starting to run out of ideas, since the tv says it prefers the mode you tried and the TV went black. That makes no sense. Can you try the pi on another screen?

I’ll try the Pi on another screen tomorrow, maybe something into the Sd was corrupted, fortunately i have an image backupped…
I’ll let you know…Thanks for the moment…

Well, finally i solved this issue…
I went into settings-video calibration menu and i have manually adjusted the overscan size until it fits the total screen suface of my TV!
I’'ve never figured was so easy
Thanks in advance

This shouldn’t be necessary and is a dirty workaround that results in diminished picture quality. You should be adjusting the aspect ratio settings on the TV. The selection should be something like just or just scan.

You mean overscan?
I already search for overscan settings on my TV without finding it
I post here the config.txt on my Pi2


However i’m experiencing frequently freezing problems on it

What’s the make and model of the TV?

Remove the overclocking and overvoltage settings and your freezing should be gone.

My Tv its a Ssmsung QE55Q7FAM

What standard settings fo a Pi2, 900 mhz, core 250, overvolt 1?

If you remove those lines the RPi will automatically use default frequency and timings.

Should be
Settings Picture - Picture Size Settings - Picture Size - 16:9 Standard

For your second question just remove them and Pi will work with defaults as @darwindesign wrote

Due to frequent freezes problems i have rewrited the SD with Win32DiskImager writing an image previously saved, the screen size behavior it’s gone, now it’s fine without needing of recalibration…
Now i have to check if the freezes still going on in order to decide if my SD has some problems, or the Pi itself or the alimentation…
We’ll see…

To determine the state of your SD I would recommend to image with Win32DiskImager, then do a full write test with h2testw, then if the test comes back with your SD being error free then restore back the image you made with Win32DiskImager.