OSMC on Raspberry Pi 2 extremely slow

I have installed OSMC last year on my Raspberry Pi 2 and from what I remember it worked fine. Now, I have just done a new install (didn’t really use it over that time as still getting the system set up) with the Jan 2016 version, and I am getting about 6.5FPS! Temp got up to about 70C in 5mins of playing a file. I am using it to connect to a myth backend on my NUC. Kodi works fine on my Ubuntu PC, so it is a problem on the Pi for sure.

When idle, CPU-KODI is at about 12%, when playing, its at about 280% (though each core is about 60-80%).

Anyone else having this issue? I have not changed any overclocking options etc.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

I went in and enabled all logs, then rebooted the Pi and opened a myth recording for about 20 seconds then uploaded the log: http://paste.osmc.io/batovigozi

I am using a generic remote that actually detects as a USB keyboard. I have made a keyboard.xml keymap so that I can enable and disable hdmi through .sh scripts. I have also installed the mythtv PVR addon that links to the server on Ubuntu on a NUC. I have a keyboard and mouse that I can use linked via a usb switch, however, they were not used in this test, just the remote.

I also changed to a manual ip address.

Any other info needed or tests you want me to run?

Edit: just found a video that played smoothly for a little bit (another recording), and the audio went out of sync very quickly and got worse over time.

  1. I assume you have under clocked your Pi on purpose due to the heavy usage?
  2. So you are trying to play original Myth recording (MPEG2 stream) that are not converted to H.264, correct? If that is the case than the high CPU usage is normal. You only could avoid it by purchasing the MPEG2 codecs and add them to config.txt.

I haven’t changed the clock speed at all on the pi.

So if that’s the case, the pi is still pretty useless for media stuff? That sucks, I just wanted to use it as a node to play streamed tv and recordings over the net!

So just pay the small fee to get the MPEG2 codec so the Pi can handle it.

Well from the logs it has definetly a changed config. So if you have not done it it must have been an alien.

Purchase the codec license from Raspberry for a few bucks and you are set

With the clock speeds, what are the defaults? Maybe that’s the issue (I don’t remember changing them). I will change them back and see if that helps.

As far as the codec licencing goes, before I purchase it, I want to know that that is actually the problem. Plus, if I still cant get netflix running on the Pi, I may look at other options rather than get the codec.

Netflix will not work on the Pi until Netlfix decides to allow it. And that will probably never happen :unamused:

Netflix could work on the Pi, but because of DRM they will probably never allow it. I have a TCL Roku TV (linux is the OS for the TV) that supports Netflix, so I CAN work on linux. But again because of DRM they will probably never release the code to support it.

Just go to MyOSMC Overclock there you can set it to “normal”

well playing MPEG2 encoded sources on the PI2 always will be hard on the CPU without the codec license

Check out the Vero - OSMC :wink:

1 Like

OK, I have installed the Novemeber version of OSMC (which I am 99% sure worked before) and its having the same issue. The log for that is: http://paste.osmc.io/ofumawidop and it appears the overclocking is normal again?

The strange thing with that (I just realised) is that I had only just re-installed it when I made the first log, so I KNOW I didn’t touch the overclocking options (that would have been on the installation before).

I have also experienced a few lock ups now, so I am actually starting to wonder if the Pi is faulty (maybe ram or CPU) and that is what is causing the issues. I may try a different card as well, but I don’t think that’s it. I will try my original model B Pi and see what happens with it, or try borrow a Pi2 off a friend.

I won’t do the vero, as it is still an ARM chip and will have the same netflix issues that the Pi has. If I do something else it will be some kind of an x86 chip that is low power etc.

With this issue, I am thinking its not the codec issue, even in the menu it sometimes starts to lag.

I can not see the relation between the CPU and Netflix. That is a software support question and will be possible on the Vero due to the fact that you can run Android on the Vero.

True, so you could just install the netflix app, kodi and even chrome into android. Any idea when there will be an Android version for the Pi?

Well, Android it self is already there Google Groups
If your question is when there is a useful Android implementation for Pi then my glass bowl is as good as yours

OK, quick update.

I have tested openelec as well now, and all the SD files play fine, the 1080 files chunk up a little but don’t seem to loose sync between video and audio.

In OSMC the SD files do not freeze and continue too much, but they do loose sync. So I am 99% certain that there is a second issue than the codec. So I am thinking the codec may fix the problem in openelec, and am thinking of getting a registration and giving it a go, however, I don’t believe it will fix the issues in OSMC. I’m also thinking that with the HD files it may be something to do with the network, but the only way really to find out is test the codec.

Once I get the registration, I can use it as many times as I want in as many OS’s as I want (as long as its on the same pi) cant I?

Yes
But just a reminder that only helps for MPEG2 so ensure that your streams are MPEG2

1 Like

How can I check if they are mpeg-2? I am pretty sure they are but is there any way to check while playing them within kodi?

Also, to get the codec, is there any way to get to the page from the main raspberrypi.org site? I can not see the option in the shop! Or have they forgotten to update the link on their site?

Press “o” while playback

http://www.raspberrypi.com/mpeg-2-license-key/

Last but not least while I don’t believe that this is your issue you might want to try to downgrade the kernel to check if your problem go away by that.
Execute sudo apt-get install --reinstall rbp2-image-4.3.3-3-osmc and reboot afterwards

1 Like

This did not fix it, I think there is something a bit out with the audio sync in osmc that seems OK in openelec.

Tomorrow I will order the key for the codec. I notice SD broadcasts use MPEG-2 audio (compared to AC3 in 1080 broadcasts), so this may fix that problem as well.

Thanks for the o tip. There is a lot of info there that is handy, and I don’t need to put it into debug mode to see the CPU usage.

One thing I noticed is that the CPU’s never get up to 100%, so seems weird that the problem is happening as I thought the ff-mpeg codec would just use more CPU and cause issues when the CPU reached its limit.

OK, codec key ordered, will test that out when it comes in.

I have also noticed in the Jan version of OSMC that the overclock options are not set to normal by default! I installed openelec as well as an older OSMC and they were correct, wiped the card and installed Jan 2016 OSMC (the latest) and the overclock options has changed from 900 down to 850! That happen to anyone else?