OSMC on Raspberry Pi 4

Am I to understand that OSMC is not working on RPi 4’s yet? I have tried installing not only the latest version of OSMC but also 2 versions back and all I get is the rainbow screen. I have tried 3 different SD cards, I have used the OSMC installer and Etcher and used 3 different RPi 4 boards. Nothing is working. I have used these same boards and same SD cards with Debian and they work just fine. So I am very sure it is not my boards or SD cards.


That’s correct, yes.


FWIW I had quite a lot of issues trying to get Libreelec working on the Pi4 and ended up installing Kodi manually on Raspbian Buster and then setting it to auto-launch. There are still issues with screen-tearing on menus, but otherwise it’s working OK.

I certainly think the eventual OSMC release will benefit from what will, by the time it launches, hopefully be a more settled Pi4 environment.

Hi is there anything new regarding raspberry pi 4(b) support?

1 Like

no, just wait

Ah :poop:, after playing with config.txt and adding some lines (boot_delay=1 and enable_uart=1) that I had found in different forums (related to RPB4 rainbow screen but not to OSMC) I have just found this thread where I can now read that the OSMC on RPB4 is not yet supported :frowning:. Our OSMC on RPB3 is freezing from time to time leading to a frustrated family in the living room. So I ordered a brandnew RPB4 and promised to fix it before xmas :christmas_tree: :santa: lockdown occurs… :grimacing:.
@Toast’s latest reply here is a few weeks old and I am hoping that we will be able to boot this baby soon :pray:.
Meanwhile, I am flashing a new microSD and am hoping that the crashes stop occuring with my old RPB3 (yes, it has active cooling and a sufficient power adapter). :unamused:
Take care and stay healthy!

It was answered (yet again) in the other RPi 4 thread just one day ago…

There is nothing stopping you from running Kodi on a RPi 4 right now though. It is supported by LibreElec and it runs on Raspbian/Raspberry Pi OS.

1 Like