OSMC on Raspberry Pi- no network

Dear all.
Just installed OSMC (alpha 2) on a Raspberry Pi.
I do not use DHCP but fixed IP addresses instead.
Obviously OSMC expects to receive an IP from the router and it fails of course.
The problem is that I do not see a menu where network settings may be set up.
There is no icon under Programs menu.

Exiting kody via pressing “exit” and then “esc” key on the keyboard doesn’t seem to work either so I can’t get even console.
It is pretty much unusable at this stage for me.
Please advise.

Actually, since Alpha 2, static network configuration should be working. Are you using an Ethernet or WiFi connection?

Sorry to hear that, but that’s why it’s an Alpha build.

Dear sam_nazarko,
Thank you for your answer.
I connect the device via a wire to a switch which is connected to a mikrotik router.
What is strange is that there is no menu for a static IP setup at all. It just missing.
Otherwise the scrolling between the menus is much faster compared to raspbmc.

Kind regards

At the moment there is no Kodi settings addon to allow configuration of network (and other) settings - this is not ready yet but will be before OSMC launches.

What Sam refers to is pre-configuring your network settings in the installer - if you run the mac/windows/linux installer again and look carefully you will see an option “configure network manually” on the networking page. Tick this box and the next screen should allow you to enter your static network settings.

Try this and let us know if it works for you.

Dear DBMandrake,

Thank you for your input.
I guess I overlooked the IP configuration during the installation process. Just did a clean install and saw the setting I missed.
Thank you very much again.

Everything should be fine now.
Kind regards.

Please let us know whether this works or not



Dear sam,
Unfortunately no positive result on the reinstall with a fixed IP setting can be reported.
The system remains with a DHCP settings active.

Best regards.

I will investigate shortly



I installed Alpha 2 and then made an “apt-get upgrade”, this installed “OSMC-network” package, after that I lost network connection in my Pi, so I’m making a new fresh install.



Seems I did something to break the network package. I’ll investigate and get back to you when that’s resolved



I confiured the installer for the RPi to use wireless with SSID and password,
but when I am booting OSMC is does not connect (the NIC worked fine in OpenElec).
Is there a way to do the network-setup manually on the SD-card via some config-files?

This is likely a bug and should be resolved in Alpha 3


I am seeing the same thing, but wanted to let you know that after the install the correct wifi config is in the /boot/pressed.cfg file if that helps.

osmc@osmc:/boot$ cat preseed.cfg
d-i target/storage string usb
d-i network/interface string wlan
d-i network/auto boolean false
d-i network/ip string
d-i network/mask string
d-i network/dns1 string
d-i network/dns2 string
d-i network/gw string
d-i network/ssid string xxxxxxxxxxxxxxx
d-i network/wlan_keytype string 1
d-i network/wlan_key string xxxxxxxxxxxxxxxx

There has been some work on improving network support and hopefully this will resolve your issues in Alpha 3



OK, sounds like you know what’s up here so I will move on the messing with other areas :smile:

I am using OSMC Alpha 3 and I am not getting wireless either. I am pretty sure that the debian base is reading the nic and loading the appropriate module for my nic. It’s hard to tell because “lsusb” isn’t available on alpha 3, I haven’t found where the usb device would be located like, “/proc/bus/usb/devices” (cat /proc/bus/usb/devices | grep -E “^([TSPD]:.*|)$”) and I am recieving an error on boot about “script failed - osmcsetting.update”.

What I have tried so far is:
1.) Explicit IP addresses on a manual setup like: etc. in an edit of the preseed
2.) Loose IP addresses on a manual setup like: etc. in an edit of preseed
3.) I took out the manual settings and set the boolean to true from false to see if DHCP would kick in…

No avail.

I went further and did cat /proc/modules and I do see a module loaded for my rtl2800 series usb nic. So, I am assuming that the module works fine in the kernel. I didn’t have an issue with it in wheezy and raspbmc 13 or 14.

I have noticed that iwconfig or iw is not available and ifconfig is listing 2 different ethernet devices. They have separate hwaddr. One is the wired and other is wireless. Now, how to force base to associate…

edit 2:
I used wpa_supplicant to associate with the AP and got a ipv6 address, still no net tho… tried dhclient wlan0 and dhclient is not found…

Will be fixed in the real Alpha 3, this is just a proposed version.

I just noticed that DHCP works almost in the proposed alpha 3 version, just the nameserver isn’t set.
If you configure it manually in /etc/resolv.conf everything works as expected.
That also fixes the ‘Script Failed!: osmcsettings.update’ error popup.

@sam_nazarko Thanks brother. All in all so far, NICE! This OS is elegant and snappy! It is the best OS for my pi yet. Keep up the good work! You have put in a lot of time and thought and I applaud your efforts!

@abraxxa Thank you! I’m going to wipe, re-install and try!

In the absence of lsusb checking dmesg should show you whether the network driver was loaded or not.

It’s normal for resolv.conf to point to as we use Connman’s DNS forwarder, however the dns forwarder is not being configured correctly due to a connman bug.

We’re aware of these problems and as far as I know they are fixed in our current test versions. If you’re both fairly comfortable with linux you could try downloading the proposed fix for /usr/bin/preseed from here:


copy it over the old one and make sure to sudo chmod a+x /usr/bin/preseed

Then run sudo /usr/bin/preseed to re-process the preseed.cfg - this should set up your network interface correctly. (If not there should be useful error messages in the system journal from the preseed script)

Some feedback on whether this works correctly would be appreciated.