OSMC on Raspberry Pi with HP RC6 IR receiver and Harmony remote

Hi guys. I reinstalled the latest OSMC and with that lost my remote functionality.

The receiver is the classic HP RC6 IR receiver connected to the Pi via USB.

-Gen 1 Rpi
-HP RC6 ir receiver
-OSMC latest 2017

The devices from the Logitech software that I’ve tested is the Microsoft Media Center (used to work) and the new Kodi OSMC device also listed under Microsoft. None work at all.

Any advice? I read online that a custom keymap.xml might be needed, but none i’ve found seems to work.

lsusb shows:

osmc@osmc:~$ lsusb
Bus 001 Device 005: ID 1b1c:0b29 Corsair
Bus 001 Device 004: ID 1934:5168 Feature Integration Technology Inc. (Fintek) F71610A or F71612A Consumer Infrared Receiver/Transceiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Make sure RC6 decoder is enabled in My OSMC -> Remotes.
You may need to select a profile for your remote.

Thanks @sam_nazarko I will try that. However it’s bit hard without any input device… maybe I can use a phone I have.

I did a dmsg:

[   14.545931] Loaded IR protocol module ir-rc6-decoder,                       but protocol rc-6 still not a                                vailable
[   14.546336] mceusb 1-1.2:1.0: Error: request urb status = -71
[   14.611529] mceusb 1-1.2:1.0: Error: urb status = -71

Then I tried to install lirc, but it has unmet deps and will not install on this raspbian it seems.

Well as you seems to have SSH access you either can use the build in web interface as a remote controll or alternatively install vnc server

Thanks, thats a good idea.

LIRC is already included in OSMC. Don’t try and install it or you will have problems.

Something seems wrong with the receiver / dongle. Try it in a PC or another device.

Ok, I tried to reconfigure, and it said it was missing.

osmc@osmc:~$ sudo dpkg-reconfigure lirc
dpkg-query: package 'lirc' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: lirc is not installed

@sam_nazarko, you were spot on. Had to enable in remotes. Would it be possible to auto-enable like before under XBMC?

It’s disabled by default to avoid duplicate button presses.

See dpkg -l | grep lirc | grep osmc for OSMC LIRC packages, which are already installed.